Lost workflow: workflowset.meta

Hi all

I made a change to the name and location of a workflow on the server and when I then tried to open it got the following

I’ve notified the team that installed Knime Server for us (to ask how to restore from a backup too - although I don’t see that this has been set up…)

My only hope is that my colleague (who is not on site today) has a local copy!

Does anyone have any idea what could have happened?

It’s a pretty severe error (and a very important workflow… :frowning: )

Hi @zedleb

What is your KNIME Server version?

What if you download a copy of this workflow locally and try to open it, do you get the same error?

1 Like

Hi @ana_ved

Many thanks for your rapid response.

We just installed on 10 Feb so I’m thinking it’s the latest version (can you let me know where I can check?)

I get the same error if I right-click Open as Local Copy.

I’ve had a look in the workflow repository on the server and the folder size is tiny - so I think we’ve lost it.

The guy who did the install suggested that the copying to the new location failed. He suggested looking in the trash folder and I am able to see data in there - is it safe enough just to pull those folders straight back into the workflow repository?

What really worries me is the lack of a back up. This was a fairly straightforward manipulation (change of name of workflow, new workflow group and move to this workgroup). Losing the entire workflow is close to a catastrophe…I will post the logs events that our installer suggested could be at the root of the problem.

08-Mar-2021 09:29:04.801 SEVERE [https-openssl-nio2-8443-exec-1] org.apache.cxf.jaxrs.utils.JAXRSUtils.logMessageHandlerProblem Problem with writing the data, class com.knime.enterprise.server.rest.api.v4.jobs.ent.JobList, ContentType: application/vnd.mason+json
08-Mar-2021 09:53:23.612 SEVERE [https-openssl-nio2-8443-exec-6] org.apache.cxf.jaxrs.utils.JAXRSUtils.logMessageHandlerProblem Problem with writing the data, class com.knime.enterprise.server.rest.api.v4.repository.ent.WorkflowGroup, ContentType: application/vnd.mason+json

Hi @zedleb

I sent you an email via our support channel.

But yes, you should be able to restore the file from the server bin.

By any chance are you working behind a VPN/ is the server repository located in a shared drive?

Best wishes

Hi Ana, many thanks. My colleague did have a local copy which she has reloaded so I won’t risk the move from the bin (I’m a little confused by all the metadata files and where to put them!)

Yes we are all working behind a VPN at the moment.

The server repository is on a drive that does have a shared repository for outputs - would that mean that there’s a shared element to the drive too? Server admin not my area of knowledge…

Best regards,

Hi @zedleb

I am glad all worked out in the end!

I sent you an email explaining a nicer way to restore files from the Server bin in the KNIME AP, so you do not need to mess with the files in the Repository. Perhaps you did not receive it, and I am sorry about it. In any case, you can generally also try the server recycle bin view in KNIME (go to view>Other > KNIME Views >Server recycle bin). This should open a new view in KNIME AP, and if you are logged in to the server in AP, you can restore items by right-clicking on it and saying “restore”.

I’d like to understand a little bit more of what happened, so if you would have a few minutes to spare for a call – please let me know.

Best wishes

Hi Ana

Happy to go over this. I’ve emailed you at Knime.