LSTMs problem IN Knime, sample WKF

Hi everyone, I was replicating a workflow found on the knime site, but without applying changes it gives me the following error:

ERROR Keras Network Learner 3:148 Execute failed: An error occurred while creating the Keras network from its layer specifications. Details:
module ‘keras.layers’ has no attribute ‘recurrent’
Traceback (most recent call last):

  • File “”, line 5, in *
    AttributeError: module ‘keras.layers’ has no attribute ‘recurrent’

Can you help me?

The original source :

[Multivariate Time Series Analysis: LSTMs & Codeless | KNIME](Multivariate Time Series Analysis: LSTMs & Codeless | KNIME)


Hi @And,

my first guess is that something is not right with the conda environment.

Are you able to execute other workflows with the Keras Network Learner node?
Which operating system are you using?
Which version of KNIME Analytics Platform are you using?


Hi @And,

I uploaded a version of this workflow including a Conda Environment Propagation node, which will create an conda environment with all necessary packages.

Please give it a try and let me know whether that worked for you as well :slight_smile: I tested it on windows and it worked fine.


I Kathrin,
thanks for the upgrade workflow,
Sorry if I answer only now.
I proved your new wkf, i used knime 4.6.0 (now in can’t update) on windows.
I use conda in local 4.9.2 (but i don’t know if pvm use the il my local or Enviromment ??
ok libraries are Enviromment )

the “KERAS NETWORK LEARNER” now work!!! But not work next nodes

knime.log ;

WARN : KNIME-Worker-106-Keras Network Executor 3:151 : : Node : Denormalizer : 3:188:154 : Some column(s) as specified by the model is not present in the data: [t1, t2, hum, wind_speed, weather_code, is_holiday, is_weekend, season, Month (number), Day of month, Day of week (number), Hour]

This is configuerd node Keras Network executor:

This is second partition of node partition

Thanks for support


Hi @And,

thanks for sharing already a part of the KNIME Log. Unfortunately it doesn’t include the error message from the Keras Network Executor node (these are just some warnings).

Can you please share the full KNIME Log with me? E.g. by reproducing the error and then going to View → Open KNIME Log and saving it in a file?


Hi Kathrin,
I cleaned the knime log file, and re-launched the wkf from the beginning.
The complete knime.log file and file console is attached.


knime_log_LSTM.txt (7.9 KB)
knime_console.txt (3.7 KB)

Hi @And,

according to the error message TensorFlow is not installed in your environment.

I updated the Conda Environment Propagation Node in the workflow on the KNIME Hub. Can you please give it another try?


Hi Kathrin,
I have update the “node environment”, and also I have inserted a check as I leave you in the drawing below in Keras Network Executor.

Now works!!
Thank you for the support.

Hi Kathrin,
I am writing to you only to update the other flow, as you have rightly done in the flow “Multivariate_Time_Series_RNN_Keras_Training”, the “Conda Environment Propagation” it must also be put in the flow “Multivariate_Time_Series_RNN_Keras_Deployment”.
To have the two flows aligned.
As in the picture below.

thanks for the support !!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.