MDMP data dump file

Dear community,

I recently discovered that every time knime crashes it automatically creates huge log files of extension mdmp inside its installation folder. Is there a way to disable this feature?

In addition, if I run knime via batch and the memory is not enough, java creates the same type of files but inside Windows/System32 folder. This is a big issue for me because my space gets filled up completely after a few errors. Do you know how to prevent them to be created or how to manage the heap memory to avoid reaching 100% of usage?


Unfortunatelly I have the same problem: every time knime crashes it creates a very big (several Giga) mdmp file that fill my hard drive preventing any application to run.

Is there a way to disable it?

Thanks in advance

Hi @venturaz87, @iiiaaa,

These mdmp files you’re seeing are so-called Minidump files. The Java Virtual Machine (JVM) produces these files such that you may diagnose what led to the crash. To prevent your JVM from creating these Minidump files on crash, can you try putting the line -XX:-CreateMinidumpOnCrash into your knime.ini?




Thanks @marc-bux. I will give it a try.

Just to know: do you think this is going to prevent the minidump created inside the knime installation folder or also the ones created in system32 when running on batch?


Hi @venturaz87,

I would think the parameter prevents the minidump generation on both folders. Let me know how it goes!



Hi @venturaz87 and @iiiaaa -

We’re still investigating this MDMP dump issue. In the meantime, can you provide any additional detail on why KNIME is crashing in your case? Thanks!

Hi @ScottF,

KNIME was crashing while opening. I do not know why, but it was taking ages trying to open up, until it ended up failing. And while failing, the mdmp was created.

Hi @venturaz87 -

Were you able to eventually solve your issue with the long KNIME load times? If so, how? And do you happen to have the MDMP file still, or did you delete it already?

Sorry to ask so many questions, but this is a tricky bug that we’ve had difficulty reproducing, so the more detail we can glean from users like you who have run into it, the more likely we are to be able to pinpoint the problem. Thanks!


We uninstall and reinstall knime and then was ok. Regarding the mdmp, we removed manually because it was filling up the C drive memory.
We thought it was a memory issue in opening knime (memory overwhelmed, above 90% or something) but we made some tests, and all was ok. It is very difficult to understand why that happened.

Hello @marc-bux,

The line -XX:-CreateMinidumpOnCrash in the init file prevented the creation of the minidump only inside the KNIME installation folder.
Unfortunately, today I was running a knime workflow via Task Scheduler. The memory of the server went almost to 100%, this caused the job to be stopped and the minidump to be created inside the system32 folder.

I am wondering if this minidumps are not related to the third party app anymore but to windows itself. Do you have any idea on how we can avoid having them created also in the system32 folder? It is quite annoying, especially if they are very big (I had 10 of 50GB almost today).


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.