Metanode Templates on Server - Break Links to All or Change References for All?

#1

We are using KNIME server on AWS to deploy a model. The workflow was built locally and contains a lot of metanode templates. The workflow will not execute on the server due to these templates. Is there a way to (1) break the link to all metanodes in the workflow before we deploy? There are a lot of template nodes scattered throughout. Or possible (2) can we change the reference to all template metanodes to the server in a scalable way, again, there are a lot of metanode templates scattered throughout the workflow. We don’t really need the metanode templates to be accessible on the server at this time for anything else.

0 Likes

#2

Hi @San_Diego_Web_Analyst,

The solution to this problem is to disable update of links at workflow loading on the server. For this you would want to set
com.knime.server.executor.update_metanodelinks_on_load=false
in knime-server.config. Note, that this will disable link update for all workflows on the server, not only the one that you try to fix now. The parameter is modified at runtime, so you do not need to restart the server and it is picked up dynamically. The linked metanodes contain the current version of the metanode template at the time of saving the workflow, so the template version in the execution on the server will correspond to the version at the moment of the last update locally in the client before upload.

Alternatively, you can use workflow-relative paths and move all templates to the server keeping the same relative location in the directory tree.

Unfortunately, neither option 1 nor option 2 are feasible globally in the current Analytics Platform. Of course, it is possible to to those one-by-one on each metanode, but that’s not what you were after. We are working to improve the UX working with linked templates and there might be new features in the next release in December.

Best regards,
Mischa

2 Likes

#3

We are deploying KNIME server through the Amazon Marketplace. I can see the config information but I don’t see any way to edit it. How would I access this information when KNIME server is deployed this way?

0 Likes

#4

Hi,

what you would need to do is to SSH to the instance on AWS and modify the aforementioned configuration file. There are more detailed instruction on ow to connect here in the documentation.

The change should be picked up at runtime according to the documentation so you do not need to restart the server. However, if it will not work out, please try to restart the server using the command from here

Best,
Mischa

1 Like

#5

Did the previous suggestion help to resolve the issue?

0 Likes