Microsoft SQL Server Connector Issue

Hi All,

We want to use our Azure SQL Server and connect it with Knime. Our server is in the cloud and not locally in desktop.
I use the Microsoft SQL Server Connector node in Knime, entering the correct host name, database details, credentials etc but I keep receiving the below error:

"The TCP/IP connection to the host database , port 1443 has failed. Error: “connect timed out. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.”

P.S I’m able to connect and work on the server with the same settings so the issue is only when I try to connect it with Knime.
I’ve found in other threads that I need to ensure TCP/IP is enabled in the SQL Service configuration manager, but as my server is on the cloud and not locally, I don’t have the option to do that.

Any ideas?

Thanks in advance,

I don’t use Azure, but for my remote server I was never able to get the Microsoft SQL server connector to work even with exactly the same setting.

At least for me connecting to a remote db server the “DB Connector” worked. in DB type you can select SQL Server and the driver I used was SQL server v7.2.0. The data base url I only put my server jdbc:sqlserver://Server address. But the key was to put the parameters in the JDBC Parameters section e.g. Instance name, database name integrated security.

Is there a connector for Azure db if above doesn’t work?

sorry cant be much help.

1 Like

Can you connect to a local sql server instance?
I had issues with my local instance and was searching forever (literally for months) until i found this post


1 Like

@Daniel_Weikert @kb2010 thank you both for your answer.

It seems that the issue was with the version of knime. I was using 4.4.4 and kept getting different errors after I was managing to fix one.

2 of my colleagues updated to 4.6.4 and they were able to run it without any issues or extra configuration and it worked for me as well. So just update my knime version :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.