MISSING Conda Environment Propagation

Hello, I have this issue where, when I run my workflow in KNIME server it gives an error and says I am missing one of my nodes (Conda Environment Propagation) however, when I run it on the PC it works fine. Appreciate any help to fix this issue.
image

Hi @kanishka271

I assume that extension containing the Conda Environment Propagation node is not installed on your KNIME Server (while you have it on your local machine, and this is why it runs fine there).
The solution would be to ask your admin to install the KNIME Conda Integration on the Server.

Hope that helps :slight_smile:
Best,
Alice

2 Likes

And in case your AP version doesn’t match your executor version, we recommend updating to 4.6

I will cross check with my KNIME admin however, the issue is this workflow runs daily. it failed with the same error twice last week and ran successfully in the rest of the days. which is strange.

Yes, please keep us posted if the issue got resolved! Did you change anything between the failing days and the successful runs? What versions of the AP and the executor are you working on?

So from 4.5 to 4.6, the Conda Environment Propagation node was moved out of the Python extension into its own extension. And varying versions between AP and executor might cause some hick-ups.

I did not change anything during the successful runs I am working on the 4.5