MISSING Scorer Node (Standard KNIME Nodes) on Server


I’m having a serious but very strange issue on the knime server. I designed a workflow locally on my machine (knime analytics platform 4.2.1 and deployed it on our knime server. Then if I want to execute the job on the server it says that there are some missing nodes on the server.


The funny thing is that the missing node is the standard Scorer node which should be installed at any time. I have also used this node in different workflows on the server and they are still running!!

I don’t know what to do and I’m totally clueless how to proceed from here. Tried all different kind of things, like updating my knime, deleting and deploying again but nothing worked and I found no solution in the web.

Thanks for your help.

Best regards,

Hi @ArminFan,

Which version of KNIME Analytics Platform is your KNIME Server using as Executor?




I solved it now by reinstalling knime version 4.1.3 on my local machine. Nonetheless this is pretty weird and I would prefer the newer version of Knime.

1 Like

Hi @ArminFan

if you have locally a bigger KNIME Analytics Version installed than the executor on your KNIME Server. You can imagine this like calling code which was not developed til now.

In this case the new implementation of the KNIME Scorer is a future KNIME version.

1 Like