Missing values working wrong

I have a problem with a missing value node. Following configuration it should insert previous version, but instead there is a constant value inserted. When I tried same workflow but with significantly reduced data in the input it is working fine. Basically for 12 lines it is working great, for approx 3000 it fails completly.


csv_read_missing_values.knwf (101.8 KB)

Has anyone faced such a behavior?

Hello @TomekKis,

and welcome to KNIME Community!

Think this is problem with configuration/data you have and not that something is working wrong. You have configured upper Missing Value node to take Previous value but at begging of you table you have missing values so those values can not be replaced…

Can you tell us a bit more what are you trying to achieve? Maybe there is some other node(s) to get you there.



Hello @ipazin

I do not expect to fill the values if those are not exist.
When I check the workflow through node 33 there is following result which is correct:

But when I go through node 30 which is basically the same and only CSV is bigger it is not working:


Hello @TomekKis,

I see the issue now. Still not a bug :slight_smile: You did in-table view sorting. That is just for view/exploration purposes and doesn’t affect downstream nodes. Use Sorter node before Missing Value node and then apply Missing Value node in order to desired result.



Thanks a lot


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.