MySQL Connector not working when running workflow on Knime Server

Hello everyone!

I’m new on using the knime server, and now im trying to feed databases in MySQL on a daily basis.

The worlflows are fine when executed in Knime Platform (localhost). However, when I try to go through them in the Knime Server it seems that they’re unable to connect to MySQL.

This is what the error message:

ERROR MySQL Connector 0:939: Execute failed: Communications link failure The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.

Investigating this error with the IT team (the team is responsible for the DB management on MySQL), we’ve thought that error was due to the Knime Server’s IP has not been granted access to the MySQL. Thus, they changed the configuration so the Knime Server could access the DB from MySQL. However, the error still persists.

Do you guys know how to handle this error? Is there any config that needs to be adjusted?

Here’s a print of the workflow and the error on the knime server:

Thanks in advance,
Alan Dias

Hi @alanmdias , is the network opened between the Knime Server and the Mysql server? Can you try to connect to your mysql server with the same credentials from the Knime server, but using a client other than Knime?

1 Like

Hello @bruno29a ! Thanks for your answer!

Sorry but how can I check if the network is open between knime server and mysql server? DB subjects are new to me.

I can connect through mysql workbench. Does it count?

Hi @alanmdias , connecting via any client such mysql workbench counts, yes. But are you connecting from the Knime Server though?

1 Like

Hi @bruno29a, i’ve already connected via workbench using my credentials, which is the same I’m trying in Knime Server.

I’m able to connect through Knime Desktop, but when I try through knime server it doesn’t work.

Do you know if I should make some additional setup at JDBC driver?

Hi @alanmdias , you have not confirmed if you connected via workbench from the Knime server though. This is to test if you are actually able to connect to your mysql server from the Knime server in order to determine if the issue that you are having is related to knime (that is you can connect to mysql from the knime server, but not via Knime, in which case it would be a knime issue), or if the issue is related to the fact that your server does not have an open connection to your mysql (in which case, nothing would be able to connect to mysql from the Knime server, and it’s a firewall issue, not a knime issue)

1 Like

Hello @bruno29a ! Sorry, I think I got confused

Via workbench from the Knime server would it be:

  1. through a workflow that is on the knime server?

If yes, I can connect when I run this workflow in Knime desktop (as in print below), but when I run this same workflow in Knime Server, MySQL node can’t connect

obs: the credentials configured in MySQL node are not the same credentials as my Knime Server user. I couldn’t connect to MySQL node using Knime Server credentials even though running node from Knime desktop

  1. or from MySQL workbench using Knime Server credentials?

If yes, I also tried to connect to mysql server through mysql workbench using Knime Server credentials, but it was not possible. However, I am able to connect to the MySQL server using the user credentials that TI on the aws server.
To simplify:
user alan.dias (knime server) = not ok
user alan_dias (dw aws) = ok

If it is neither of these two alternatives, could you guide me on how to perform this test to connect to my mysql server from the Knime server?

I hope I clarified it better. Thanks for your help and patience :smiley:

Hi @alanmdias , neither of the 2 will do :smiley:

Simply put, the idea is to figure out if the issue you are having is because:

  1. Your Knime server can’t connect to your mysql server (not allowed to), so it’s not an issue with Knime, but rather a networking issue between the 2 systems, and this would have to be resolved by your IT or sys admin
    or
  2. Your Knime software cannot connect to your mysql server, so it’s an issue that we and the Knime Community can try to help with.

Actually, for case 1, your IT or sys admin person can help you determine this.

1 Like

Hi @bruno29a, thanks again!

I tried asking about the meaning of “connect via workbench from the Knime server”, as i had not confirmed. In case if one of the alternatives would be valid to confirm if I could connect via workbench from the knime server.

Anyway, i got your idea :grin:

But how can i figure out 1 (issue between the 2 systems)?

According to the IT team, there is no active firewall between the mysql server (aws rds) and the Knime server, and all releases have been made, including the release for the knime server IP to access the mysql server (aws rds). They gave me admin access on the knime server.

Have you updated the knime server version?
Maybe this can help

Regards

1 Like

Hi @hmfa !

We installed the knime server last week, version 4.14. I’m using Knime Platform version 4.5. As the two versions are compatible, and we haven’t used Knime Server yet, do you think the update might help?

The first workflow that I deployed to Knime Server was exactly the same that i’m having problem connecting to mysql hehe

Thanks