Mysterious bug

Hallo,

The initial data was a subset of the data determined with a row filter.
For this data I wanted to look at the new Node Box Plot(Labs). A WARN was issued here:

WARN Box Plot (Labs) 3:30 All rows with a ‘Maxim Quattro’ in the condition column only contain missing or NaN values. This category is thus omitted.

In the critical column, the value “Maxim Quattro” is not present.
To check this I created a row filter. Strangely here you can select “Maxim Quattro”.

Führt man den Row Filter aus erhält man folgende Meldung:
WARN Row Filter 3:33 Node created an empty data table.

Patrik

Hey Patrick,

this is not a bug, but rather a feature of KNIME. In KNIME each table contains a table spec. This table spec consists of meta data about the table (min, max of numeric columns, possible values for nominal columns…). This table spec can be manipulated to be larger than the actual data. With this you can for example change the bounds in a plot or have values showing up in a value selection widgets that don’t exist in your data. You can have a look at the table spec if you right click the node and open the table output. In there you will find a tab for the spec.
If you want to sync your data with the table spec you can use the Domain Calculator node.

Hope this helps,
Daniel

1 Like

Hi Daniel,
i checked it out. You have to know how to use your own node for this. Stupid if you have to reset dozens of connections afterwards
It would be better to include this as an option in the node(s) where data is filtered. Update spec columns.


Thanks for the tip.
Regards
Patrik

Hey Patrick,

I totally agree and I like the idea of a checkbox for this.
I will update this thread as soon as I have any news on this.

Greetings and thanks,
Daniel