New Database Nodes: Write large Strings to Oracle-DB

#1

Hi @all,
I’m currently migrating my existing workflows to the new Database-Extension.
But there is on problem:
I have to write strings up to 4k characters into a CLOB-Field. The legacy databasewriter does this job perfectly. The new databasewriter throws:
“value too large for column “schema”.“table”.“field” (actual: 3535, maximum: 255)”
Does anyone have an idea what to do?
thx

0 Likes

#2

Hi there,

try mapping this column to CLOB in Output Type Mapping tab of Oracle Connector node. Or DB Connector if you are not using the dedicated one.

Br,
Ivan

0 Likes

#3

Hi @ipazin,
thanks for your hint.
I tried this, but it didn’ work…

Br,
Michael

0 Likes

#4

Hi @all,
I found the issue:
Within the DB Writer Node is no conversion to uppercase letters. So the node created a new Table “Tablename” instead using “TABLENAME” (which is the behavior of the legacy node).
Also the Column-Names are not converted to uppercase, so that I got another failure for that.

Converting everything to uppercase (tablename and columnnames) got the solution!

@tobias.koetter: Is this a bug or a new feature ? :wink:

1 Like

#5

Hi Michael,
this is a new feature. The new db framework now always quotes database identifier e.g. schema, table and column names to be consistent. If you don’t like it at all you can remove the identifier delimiter in the advanced tab. If you like the old behavior where only identifier with spaces where quoted you can enable the Delimit only identifier with spaces option in the Advanced tab of the connector node

Bye
Tobias

2 Likes