New Server Installation - JDK Path

I am trying to install new KNIME Server and and was going through the installation step and I am stuck at JDK path.

Select JDK path [/opt/knime]
/usr/lib/jvm/
The chosen directory does not contain the required product.
Select JDK path [/opt/knime]

I have install JAVA 11 as describe in the installation steps - sudo apt-get install openjdk-11-jdk

root@knime-server:/# sudo apt-get install openjdk-11-jdk

Thanks,

Hi @kamleshp ,

You would need to add the JAVA 11 path to the end of the /usr/lib/jvm/<java 11 directory> or even also add /bin to the end of that too.

Please let us know if this helps with the Select JDK path issue.

Thanks,
Zack

That didn't' help. This is what I have in /usr/lib/jvm folder

total 20

drwxr-xr-x  4 root root 4096 Aug  9 14:13 ./

drwxr-xr-x 71 root root 4096 Aug  9 14:20 ../

-rw-r--r--  1 root root 2047 Jul 22 09:14 .java-1.11.0-openjdk-amd64.jinfo

lrwxrwxrwx  1 root root   21 Jul 22 09:14 java-1.11.0-openjdk-amd64 -> java-11-openjdk-amd64/

drwxr-xr-x  9 root root 4096 Aug  9 14:12 java-11-openjdk-amd64/

drwxr-xr-x  2 root root 4096 Aug  9 14:13 openjdk-11/

knime@knime-server:/usr/lib/jvm$ cd openjdk-11/

knime@knime-server:/usr/lib/jvm/openjdk-11$ ll

total 8

drwxr-xr-x 2 root root 4096 Aug  9 14:13 ./

drwxr-xr-x 4 root root 4096 Aug  9 14:13 ../

lrwxrwxrwx 1 root root   11 Jul 22 09:14 src.zip -> lib/src.zip

knime@knime-server:/usr/lib/jvm/openjdk-11$ 



────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────

Path to system's JDK installation

────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────



Select JDK path [/opt/knime] 

/usr/

sbin       include    share      lib        local      games      bin        src        

/usr/l

lib      local    

/usr/lib/jvm/openjdk-11/bin

The chosen directory does not contain the required product.

Select JDK path [/opt/knime] 

/usr/lib/jvm/openjdk-11/

The chosen directory does not contain the required product.

Select JDK path [/opt/knime] 

/usr/lib/jvm/openjdk-11

The chosen directory does not contain the required product.

Select JDK path [/opt/knime] 





As @ztrubow mentioned, you have to get the JDK path. It’s looking for the directory above the /bin, /lib, etc.

$ readlink -f $(which java)
/usr/lib/jvm/java-11-openjdk-amd64/bin/java

In the above, you can see my java 11 install path is /usr/lib/jvm/java-11-openjdk-amd64.

$ ll /usr/lib/jvm/java-11-openjdk-amd64/
total 52
drwxr-xr-x 9 root root 4096 Aug 4 13:30 ./
drwxr-xr-x 4 root root 4096 Aug 4 13:30 …/
drwxr-xr-x 2 root root 4096 Aug 4 13:30 bin/
drwxr-xr-x 4 root root 4096 Aug 4 13:30 conf/
lrwxrwxrwx 1 root root 42 Apr 21 2021 docs β†’ …/…/…/share/doc/openjdk-11-jre-headless/
drwxr-xr-x 3 root root 4096 Aug 4 13:30 include/
drwxr-xr-x 2 root root 16384 Aug 4 13:30 jmods/
drwxr-xr-x 73 root root 4096 Jun 29 2021 legal/
drwxr-xr-x 6 root root 4096 Aug 4 13:30 lib/
drwxr-xr-x 4 root root 4096 Jun 29 2021 man/
-rw-r–r-- 1 root root 1189 Jul 22 05:14 release

So looking at your post above, it appears that your jdk path would be /usr/lib/jvm/java-11-openjdk-amd64 as well.

Regards,
Nickolaus

1 Like

Got it. I think it worked!

Thank you, Nick!

1 Like

Do I have to add /bin/java at the end or just point to the directory?
/usr/lib/jvm/java-11-openjdk-amd64

Hello,

Just point to the directory.

Regards,
Nickolaus

1 Like

knime-server-installer-4.15.1.jar knime_server
/opt/knime/knime_server/knime_executor

The installation is done via KNIME update sites (US), which are either online US (such as β€œhttp://update.knime.com…”) or zip archives (such as β€œc:\file.zip”). Register up to four update sites below, whereby you can either paste URLs or local file paths. The installer will add all bundles available in the listed update sites. For a more selective installation choose a UI based installer.
[https://update.knime.com/analytics-platform/4.6/]
https://download.nodepit.com/palladian/4.6
[https://update.knime.com/community-contributions/trusted/4.6/]
http://content.schrodinger.com/knime/extensions/

http://content.schrodinger.com/knime/extensions

https://update.knime.com/partner/4.4

Press 1 to continue, 2 to quit, 3 to redisplay
1

─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
KNIME Executor Installation…
─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────

[ Starting processing ]
Starting process Installation of KNIME Executor (1/1)
[ Starting processing ]
Starting process Extracting temporary β€˜p2-director’ application (2/5)
Starting process Querying content of update sites (3/5)
Retrieving Installable Units from
o https://download.nodepit.com/palladian/4.6
o http://content.schrodinger.com/knime/extensions/
o http://content.schrodinger.com/knime/extensions
o https://update.knime.com/partner/4.4

com.chemcomp.feature.group=2.4.5.20210716SEVERE:     There were errors. See log file: /tmp/IzPack773330030900141898Install/configuration/1660135169962.log

There were errors. See log file: /tmp/IzPack773330030900141898Install/configuration/1660135169962.log
com.dvw.knime.sap.feature.feature.group=1.0.2130.2202108031436
com.inteligand.knime.feature.group=1.9.3
com.nodepit.licensing.feature.feature.group=1.1.0.202101031753
com.schrodinger.knime.feature.nodes.feature.group=21.4.135.202111140634
com.scientificstrategy.community.features.feature.group=4.3.0.v202107100146
com.tibco.ext.feature.knime.spotfire.filenodes.feature.group=1.10.21.202006101403
jp.co.infocom.cheminfo.jchem.feature.feature.group=4.4.0.v211500
jp.co.infocom.cheminfo.marvin.feature.feature.group=4.4.0.v211500
org.knime.features.ext.h2o.dai.feature.group=1.0.0.v202112101518
org.knime.pharmacelera.feature.feature.group=1.0.0.v202004161715
se.redfield.arx.feature.feature.group=1.0.0.v201911040846
se.redfield.cp.feature.feature.group=1.1.0.v202005061246
se.redfield.node.port.orientdb.feature.feature.group=2.0.80.v201906141205
ws.palladian.nodes.deprecated.feature.feature.group=2.5.2.202208011540
ws.palladian.nodes.feature.feature.group=2.5.2.202208011540
ws.palladian.nodes.hashalgos.feature.feature.group=2.5.2.202208011540
ws.palladian.nodes.maxmind.feature.feature.group=2.5.2.202208011540
ws.palladian.nodes.oauth.feature.feature.group=2.5.2.202208011540

Starting process Installing KNIME Product (4/5)
Installation failed.
SEVERE: The installable unit org.knime.desktop.product has not been found.
The installable unit org.knime.desktop.product has not been found.
SEVERE: There were errors. See log file: /tmp/IzPack773330030900141898Install/configuration/1660135175847.log
There were errors. See log file: /tmp/IzPack773330030900141898Install/configuration/1660135175847.log

SEVERE: Installation failed with exit code 13:
The installable unit org.knime.desktop.product has not been found.
There were errors. See log file: /tmp/IzPack773330030900141898Install/configuration/1660135175847.log
Errors during installation:
Installation failed with exit code 13:
The installable unit org.knime.desktop.product has not been found.
There were errors. See log file: /tmp/IzPack773330030900141898Install/configuration/1660135175847.log

Press 1 to redisplay, 2 to quit
1

I think your installation failed because you replaced the base update site (https://update.knime.com/analytics-platform/4.6/) with the nodepit repo, and the trusted repo with a schrodinger repo.

Thus it couldn’t find the bits it needed to download for org.knime.desktop.product to install the executor.

You should leave the update sites, at least the two first ones, in the list for this installation. You can run the manual command-line commands later if you need to install third party extensions.

Regards,
Nickolaus

Okay, Will do that. Thank you, Nick.

Hey Nick,

I was able to configure my new KNIME server. Thank you for all your help!

Kamlesh

Hello Kamlesh,

I’m glad to hear it - let us know if you have any additional questions.

Cheers,
Nickolaus

I was able to get the server setup but I can not run any work. It’s just say loading… See attached screenshot.

I am getting error that says
β€œJob wasn’t loaded within 3 minutes. This usually happens if the executor is overloaded or if no executor is available at all. Please check back with your server administrator.”
It would be helpful if we can setup a remote session.

Thanks,
Kamlesh

Not sure what this mean when starting the executor

knime@knime-server:~/knime_server/knime_executor$ ./start-executor.sh
CompileCommand: exclude javax/swing/text/GlyphView.getBreakSpot bool exclude = true
Starting command line interface. Type β€˜help’ to get a list of available commands.
Note that this interface is only a temporary solution and will go away in the future.
Executor>

Hello Kamlesh,

a) did you follow the documentation to install the systemd service scripts as in [1] and [2] ?
b) if yes, you should be using sudo systemctl start knime-server and sudo systemctl start knime-executor instead of start-executor.sh.
c) Please reach out to us directly at support@knime.com for further assistance with this server.

Thank you,
Nickolaus

[1] KNIME Server Installation Guide
[2] KNIME Server Installation Guide

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.