New UI is hidding final columns when table has to many columns. How do I change this to see all actual columns?

Hi! Does any one know how to make Knime’s table view in the new UI show all columns when there are many columns? It is frustrating not seeing the last column, specially because nodes used to create new columns input those columns at the end.

When using a table with many columns, a default column gets created that says “(skipped remaining columns)” Does anyone know how to change this a make the table view window show everything?

Hi @rmonterosapri , this is a known issue with the table view in Modern UI, and I believe the KNIME team are actively investigating options for the future.

Currently if you can’t see the columns in the view panel and also not in the pop-up view options from the node context menu, then I would suggest dropping an Interactive Table (legacy) node on the workflow and linking it to the node you wish to view.

That should give you the classic table view from which you will then be able to see the missing columns.

See also

2 Likes

Thanks a lot @takbb hopefully they fix it soon!

1 Like