Newbie - filter based on keyword not working? (empty data table)

Hello, new user here receiving a “Node created empty data table” message every time I try to filter based on the word ‘eye’ (not case sensitive).

Here is my workflow:

My Column filter settings, filters out all columns in spreadsheet except my “Description” column, that I want to search for the word ‘eye’:

Column Filter results (seems to be working):

Row filter settings, on Col02 for ‘eye’:

There are rows in the column that contain the word eye and also eyes.
What am I doing wrong? Your replies will be much appreciated!

Don’t worry I worked it out! It just needed wildcards :):smile:


Hi @WithRegards and welcome to the KNIME community forum,

First, you can check the “Table contains column names in row number:” option in the configuration window of the Excel Reader (XLS) node to have the column names.

Second, using a term as the pattern without checking “contains wild cards” or “regular expression” options will filter the exact matches. If you want to filter the rows which CONTAIN the term eye then use this for example *eye* (enclosed in asterisks) and check “contains wild cards” option.



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.