No grammar constraints (DTD or XML Schema) referenced in the document

Hi all,

I would like to know how to get read of the following XML warning, always present just after the creation of any Knime node in eclipse when you look into the …Factory.xml file.

Such file always starts with something like:

<?xml version="1.0" encoding="UTF-8"?>

<knimeNode icon="./default.png" type="Learner" 

xmlns="http://knime.org/node/v2.8" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 

xsi:schemaLocation="http://knime.org/node/v2.10 http://knime.org/node/v2.10.xsd">

The warning is: No grammar constraints (DTD or XML Schema) referenced in the document."

I know that another post is similar to mine, see: https://www.google.fr/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=2ahUKEwiN6fPH4JzeAhUtyYUKHTyKDaAQFjAAegQIABAB&url=https%3A%2F%2Fforum.knime.com%2Ft%2Fbroken-xml%2F5617&usg=AOvVaw3lu-tWmSfmsAhmqES6a2z-

But there is no solid solution in the replies.

I’ve googled a lot and it seems to be an eclipse issue. The good and solid solution should be to properly configure the XML catalog in eclipse.

That means going there: Windows | Preferences | XML | XML catalog and then add a new User Specified Entry

I made a lot of tries without any success. What is the proper configuration so that eclipse can use the schema location?

thanks

Yannic

1 Like

I hope someone can answer this - I see it in some projects and not others in the same Eclipse workspace, with no obvious differences between projects.

Steve

1 Like

still no one to provide a solution?

The schema is available only at http://knime.org/node/v2.10.xsd, see the schemaLocation attribute. Therefore no local configuration is required if you have access to that URL.

Hi Thor,

I’ve the network access, no issue there. It’s eclipse (4.7.2 with knime 3.5.3 as target platform) that still displays this warning. What’s wrong with the following lines?

<?xml version="1.0" encoding="UTF-8"?>

<knimeNode icon="…/icons/kem4.png" type=“Learner”

xmlns="http://knime.org/node/v2.8" 

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

xsi:schemaLocation="http://knime.org/node/v2.10 http://knime.og/node/v2.10.xsd">

thanks

Y

There’s an “r” missing in http://knime.og/node/v2.10.xsd (“og” instead of “org”).

the missing r is missing only in my post not in my code… (issue with copy/paste, sadly)