No REST endpoint found neither http nor https working

Hello
a few month ago in ‘knime analytics platform’ I configured two new knime-servers which both used rest connections , which worked.
The server was in both cases is a apache web server, which has the certifikate installed.
These connections are working (tested in Chrome):
https://OurTestServer/knime , https://OurTestServer/knime/rest
https://OurProdServer/knime , https://OurProdServer/knime/rest

We also use administrative connections which are working (tested in Chrome):
OurTestServer: http://[::1]:18080/knime/ , http://[::1]:18080/knime/rest
OurProdserver: http://[::1]:28080/knime/ , http://[::1]:28080/knime/rest
(port forwarding by putty)

Even these administrative connections don’t work in ‘knime analytics platform’.
They do not need a certificate.
If I edit a connection to our Test- or Prodserver the error
‘No REST endpoint found’ occurs.
Other collegues can connect to both servers with ‘knime analytics platform’.

Greetings b.kochs

I removed Knime Analytics Platform 4.2.0 and reinstalled it; that solved the problem.

2 Likes

Hello,

While it’s not normally our first recommendation, I’m glad to hear that reinstallation was able to resolve your issue.

Please let us know if there is anything else you may need help with.

Regards,
Nickolaus