No such node ID error

Hey fellow Knimers,
I currently need to deploy a new workflow on our Knime Server to test out how it´s possible to use the active directory to authenticate in our data-warehouse.
I set up a fairly simple workflow:
But when i execute it i receive the following error:
My local knime client and the server are running version: 4.1.2.
These are the extensions on the server and their versions. These should be on the latest update as i can´t update them any further.

Am i missing somethig out?
I´d appreciate your help.
Best regards

Hello; I wonder if can this help? I don’t know, but I wanted to share.

I think the RowID node is unrelated to this error.
How do you think this may help?

Hi @mcfloli

can you get us the log files? IF you get this error, there is typically a second error in the log files.
We would need to see the executor log file.

Hi @Iris
It seems like logging is turned off. The file didn´t update for a few months. Maybe someone disabled logging by accident.
I referred to this guide on where to find the logs:

How can i turn it back on?

Can you check if this option is set for you:

/instance/org.knime.workbench.core/logging.logfile.location=true (in the preferences.epf of your executor)

This line wasn´t present initially.
I´ve added it now into the preferences.epf file. But still the knime.log file in the runtime folder doesn´t get updated after running a workflow through the executor.

We are also getting this same error. It only happens when we use nodes which use the new ‘DB connection’ type (dark red). Because it throws an error during the creation of the job on the KNIME Server there is as far I can see no logging on the server of this error.

The workflows works just fine when run in the executor locally on the server. It’s just that the job cannot be created which contains nodes of this type.

I´m still getting this error from time to time.

Hi @mcfloli,

Since you are saying “from time to time”, does this also only happen from time to time for a specific node, or does it always fail for the same node(s)? Does this only happen in a particular workflow, or just randomly across the board?


Hi @RolandBurger,
i mean this the way that when i edit a workflow of a colleague and save it to the server i get this error. Today i added a try/catch block to a workflow. No other special nodes were included other than the most basic ones for these operations.
Then i saved it and tried to run the workflow. Now i always get this error message. Server and client are running the same version. I double checked that. This workflow was running before i edited it.

Best regards and thank you for helping me,