Node missing

Hi there,

We've developed several nodes (but I'm pretty new to the development) and now I have a strange problem and no one could solve it so far:

A node is missing in the node repository. The jar-File is in the plugins- directory and there seems to be no problem with it. For other Knime applications the same jar does it's job... (copy / paste)

If I export the plugin as directory instead of a jar, the node appears. Is there any explanation for this weird behaviour?


hm have you tried to change the category? You can try to put it in the dropins folder too.

I've tried "/" as category but it doesn't work.

Putting the jar file into the dropins folder? Why should it solve the problem (unfortunately, I'm not very familiar with Eclipse).

Anyhow - the node is now visible... I cannot find any explanation for this behaviour... The last thing we tried yesterday was to use the directory instead of the jar file and it worked (as I told). Now, I removed this directory and rebuild the jar once more and voila - the node appears...