OME Metadata

Hi all,

I have some problems trying to read out the OME-XML metadata from our images.

Data: https://www.dropbox.com/s/dyvc1v9ufhrgkg8/Experiment-07-Scene-01-P1-A1.czi

 

In the Additional Options at the image reader I select “Append additional OME-XML –metadata column”.

What I’m getting is this: https://www.dropbox.com/s/dxinfoy25ouxbcf/2014-06-02%2015_52_21-Images%20-%200_597%20-%20Image%20Reader%28Load%20Image%28s%29%29.tiff

But with ImageJ (or in this case FIJI) I get this: https://www.dropbox.com/s/meozl2578z08hp0/2014-06-02%2015_56_52-Program%20Manager.tiff

So how can I get all the OME Metadata with KNIME?

 

Kind regards,

Flo

Hi Flo,

with the next release (to be exptected soon) this issue should be fixed. Or, if you don't want to wait, you can already use the nightly build of the ip-extension (see here for instructions). Or are you already using the nightly build version?

Best,

Martin

Hi,

I tried the nightly build and now I'm getting this:

https://www.dropbox.com/s/us2ahrn70a65bc3/xml_meta_new.PNG

So more infos are shown but compare to FIJI there are still a lot of infos missing.

 

Kind regards,

Flo

 

Hi Flo,

we are working on the problem and faced another one after updating the bioformats-library that we have to solve first. Therefore one question: what Zen-version did you use to acquire the image?

Thanks!

Martin

Hi,

yes there seems to be a problem with the new bioformats version 5.0.2 (with the 5.0.0 version it works fine).

We made a bug report and hopefully this problem will be solved soon. 

I am using a ZEN version which is not out yet so maybe there is also a problem in my ZEN version. 

So yeah it seems that we are stuck till this problem is solved.   :-)

 

Thanks a lot,

Flo

Hi,

 

Bioformats is working now :)

So what I need are those Metadata (especially the red marked positions):

https://www.dropbox.com/s/4jx4pbkwe0nazt2/OME_Metadata_positions.PNG

 

Thanks again,

Flo

Update:

 

Works with the newest Version ;)

 

Thanks,

Flo