On Server "Workflow executed successfully" but there was an error

Hey all,

I do get the message “Workflow executed successfully” when I execute the attached workflow, even if I upload the wrong file, which clearly produces an error on the local application.

The only way I can currently find out whether the workflow failed is to watch whether the last view (Table View node) is executed or not. if the data is displayed after the workflow executed, I know the run was successful, otherwise not. For this “Error Reproduction” archive, be aware that I never see the table output (also not when using the proper file), so there seems to be something else strange as well. maybe not related to the issue that I described.

Error Reproduction.knar (33.3 KB)

I hope somebody can show me a way out of this as this seems to be very strange behaviour!

We are using knime server 4.11.2

In the meantime, in the workflow messages on the server I found only one entry:

File Upload Widget 36:935:0:820 - WARNING: Connection to given URL: “file:/data/opt/knime_server/workflow_repository/jobs/e14390/object-store/9ff7d8c3826714aba3188feaca6f6db855af9562af00c7061b9f7e8c09810bc0” could not be achieved. A file system path has been provided, but access was denied

But even if this would hint towards the cause of the error, I still do not understand why the server actually deems the failed execution as “Workflow executed successfully”

Hi @dobo

I’ve tried running your workflow on a 4.11.5 server, which worked just as one would expect (displays table for correct file(s), execution fails for nonsense).

Looking at the error that comes up, it seems to be an issue with the servers filesystem. Maybe the storage it’s trying to write to is full, or the access permissions aren’t set properly. Following is a workflow from a KNIME Analytics Platform version 4.2.2 (i.e. corresponding to server version 4.11.2).
It simply writes some data to disk and then loads it again. Does that work on your server?
If it does, I’ll set up a 4.11.2 server and see if I can reproduce your issue on that.

Writing-Reading Test.knar (17.2 KB)

Regarding the “Workflow executed successfully” even though it clearly didn’t: I’ll have to do some more digging and get back to you.

Kind regards

Hi @marvin.kickuth, thank you very much for your quick reply! In the meantime I came to the same conclusion as you did. Something is not working correctly with regards to the servers file system. And actually I found the reason what causes it. It is this setting in the File Upload Widget:

The way it is documented, it sounded to me that it would be a better idea to tick this box. However, if it is ticked, it leads to this strange behaviour I described earlier.

Ah that is interesting, thanks for the update @dobo

I would agree with the documentation that generally it is safer to save files in the workflow directory. However, you are most likely fine using the system’s /tmp/ folder (otherwise it wouldn’t be an option :wink: ).

If you wanted, you could ask your server administrator to check what the file/folder permissions are on those temporary folders and/or recursively change the owner/permissions of the workflow directory to the knime user.

In any case, I’m happy it is working for you now.

As far as I can tell, the WebPortal correctly fails workflows that run into user errors. I’m still investigating what went wrong in your case (I had a similar experience a while back that was limited to the version 4.11 WebPortal, hence I suspect it might be a bug that has since been fixed in versions 4.12.x). I will update you if I can lock down the issue.

Do let us know, if anything else comes up.

Kind regards

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.