Open Street Map View - No connection


I'm trying to use the OSM Map View node to plot a set of latitudes and longitudes on a map. I can see the points, but unable to see the map view in the background. There are red 'X' marks, and no map. I think it's unable to contact the OSM server. Any suggestions? I do not have a active firewall on my computer



I also tried it on my machine and everything works fine.

So, are you able to download this image here, for instance?




Yes I am, I can access OpenStreetMaps from my browser. 

Hm. Are you able to update KNIME (e.g. Help > Check for Updates)? This is just to check if something prevents KNIME from connecting to the internet.

Yea , I'm able to update Knime . I am also able to install additional nodes through the "Install new software feature" too. 

I just installed Knime on another computer and am able to view the map in OSM there. Something to do with my current computer settings ? 

Thats weird. To be honest, I have no idea what the problem could be.

But two more tries to locate the problem:

1. Could you please select "Tiles > OsmTileLoader" in the OSM View? Maybe some missing permissions in you tmp-directory cause the problem.

2. Could you please try to view the map in JOSM (a nice piece of software that we actually use internally to display the map): to run it you can either use java web start or download the jar file an execute it via "java -jar josm-tested.jar". In JOSM just click "Imagery > OpenStreetMap Mapnik". Is the map available? If not, than we can at least tell, that's a problem of the KNIME extension ...

Sorry for not having no better solutions to offer, so far ...

Sorry for the delayed response

I'll try these options on my laptop later to figure out what the issue is since it's working on my other PC. Thanks again

Hi there,

I'm experiencing the same issues, and I assume it's due to the non-standard port used. My attempts reveal that there's a HTTPS connection attempt to on port 4433, which won't work in many corporate settings. Any way of getting a standard secure web service on standard port 443 used instead?


Any advice on this? Myself and a colleague have the same issue. The tiles loaded ok from a public internet connection (so I have some in file cache) but do not load when connected via corporate network. The proxy settings are configured in KNIME and I can update KNIME and install KNIME extensions successfully via the corporate network.