Opera reader .res file problem

Hi

I am unable to import opera .res files using the Opera reader node under HCS tools. I recieve the following error:

ERROR     Opera Reader     Configure failed (RuntimeException): Parsing of opera-file failed:

I am not sure why the files are failing, they are standard .res exported files.

Thank you for any assistance you can provide

Regards

John

 

 

Hi John,

I tried to reproduce that error message here and I couldnt.

What can happen is that if you have different type of data in your .res files (in terms of different columns/analysis values), then the node doesnt know how to parse the data into one table and will fail with this type of message:

 

ERROR     Opera Reader     Execute failed: column-definition mismatch between '/Users/Desktop/testA/Meas_01/An_01_Me01_testA(2012-12-27_19-33-25).res' and '/Users/Desktop/testB/Meas_01/An_01_Me01_testB(2012-11-23_17-52-07).res'

 

Did you try to load a single .res file? If yes and it didnt work, could you please upload this file so that we can trouble shoot?

Best,

Martin 
 

Hi Martin

Thank you for your quick response.

I have tried single files and folders with the same error - parsing of opera file failed. It doesn't give the column mismatch error you suggested though.

I have attached an example file. Thanks again for all your help.

 

 

 

 

Hi John,

I figured out that the Opera Reader accepts numeric data only and doesnt accept strings values. The only strings that are accepted are "NAN" and "NaN" (without the "") which are interperted as NaN in KNIME.

Your .res files contains "---------" and "=========" as values, this cannot be parsed.

Also you have this as a parameter name twice, which is no problem for the Opera Reader, but you will get two columns with the same name. I think this not ideal or can create problems later.

So either you re-run your analysis and leave away these separator lines in your Acapella script or you use some kind of replace function on all files before you read in the .res files.

I put this on the to do list for the Opera Reader to also accept string values, but it will take some time before this will be fixed (at least some months).

Good luck,

Martin 

Hi Martin

Thank you for looking into the issue so promptly. I will look at adjusting the output script to remove the non numeric data or failing that try to remove those columns before opening in the opera reader.

thanks again for your help.

Regards

john

 

 

Thanks for the information's posted. 

buy soundcloud plays