Optimizing subset selection based multiple objectives

This workflow demonstrates multiobjective subset selection using a genetic algorithm. It reads a (artifical) dataset with coordinates and scores for each object and a distance matrix is compute based on the coordinates. The multiobjective row selection node selects subsets based on two objectives. The data file is contained in the workflow directory.

This is a companion discussion topic for the original entry at https://kni.me/w/kV4mwI7yBXOpnsAm


On tried to install (KNIME 4.3) and look at the workflow from Christian, but the note “Multiobjective Subset Selection” is not working, because “Execute failed: Reference point is not dominated by all other points”
In fact the setting “reference point” is initiated at “0.2 1”.
This setting is not explained in the documentation Multiobjective Subset Selection (NSGA-II) – KNIME Hub
Could you please tell me why this node can’t be executed, or in other word, what is the mistake in the setting of “reference point”?

Hi @PierreI and welcome to the forum -

I tried to reproduce your problem using the settings given, but so far I’ve not been able to. If you read the node description, it provides a little bit of information about the reference point under the “Compute hypervolume” setting:

“Enables the computation of the hypervolume enclosed by the Pareto front approximations. You need to provide a reference point which is dominated by all solutions. The reference point must be entered in the text field, with the coordinates separated by spaces. The number and order of coordinates must match the number and order of the objectives. Hypervolume computation is very expensive if more than two objectives are used, therefore an approximation algorithm is used.”

Along those lines, if you uncheck the “Compute Hypervolume” checkbox do you still run into trouble? And can you provide which operating system you’re using, and how much memory you have allocated to KNIME (per the knime.ini file)?

Thanks a lot Scott and for the quick answer.
I finally achieve to run the nodes (by taping again the content of the “reference point” as 0.2 1.
Have a nice day

1 Like