Outout directory does not exist error

I am trying to unzip a downloaded zip
I am using the “Unzip Files” node
But despite browsing to select the output directory I get an error
Error: output directory does not exist

The path selected is
/Users/feargal/knime-workspace/CIA/CIA Data

The only thing I can see might be wrong (surely not) would be a space in the path name, so I have tested on a path without a space with the same result.

Any suggestions why i am getting this error?

Hey @feargal, as a quick note, if the ZIP contains a .CSV file you can just use a File Reader node to open the ZIP, no unzipping required!

Here is a workflow that I built on KNIME Hub showing how to read in multiple file types including .ZIP files: https://hub.knime.com/tardispilot/spaces/Public/latest/Importing%20Multiple%20Files%20(ETL)


Your workflow gives exactly the same error, although at least I know the path is likely to be the problem

I’m on a mac and that looks like a PC path, so it doesnt exist on my system.

You could try and employ R to unzip the data. I once had to use it because the unzip node from KNIME was not able to handle certain strange dots and underlines and empty folders in a zip file.

Here you tell unzip which files (csv) you want and it can also handle blank folders on my Mac seemingly.

I’m not sure why you keep talking about csv’s
Its not CSVs in the zip
Its a whole website

Update Hey @feargal I just tested/replicated this on the Mac and you simply need to click the folder you want to save it into then select save. So to save to Downloads, you click Browse, Single click on your Downloads then click the save button. Don’t double-click into the folder and try to save. That will result in the directory error.


Thats it. Worked a treat


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.