Overview of all scheduled Flows

Hey :slight_smile:
I already was directed to the flow that can pull all jobs on the server but is it also possible to pull all scheduled flows from the server? Like an overview of all flows with their schedule?

There are workflows on the hub that demonstrate how to do this


Hey @mlauber71 and thanks for your reply.
I already know the flow Query Jobs but this only gives me back the jobs that have already “started” or are past their execution time.
But what I’m interested in as a list of all scheduled jobs which are in the future.
The second flow you referenced gave me 0 entries back. But thank you for referencing :slight_smile:

Do you by any chance know if the second flow is what I am searching for (as described above)?

1 Like

Maybe this could do the trick? I think this is the one @Iris recommended to me once. You could also see if they are active or inactive I think.


Good thank you, as said this one currently gives me 0 results but I saw that there was some note regarding only flows visible that the user can see. I should be able to see all flows so not sure why it gives me 0 .

it could be that you have to ‘play around’ with the authentication - it asks you up front to enter credentials I think I had to do that. And yes fro my memory it would give you your own schedules.

If you want all I think you would have to try and access some sort of admin page. I have no idea if this could be done by such a workflow. Maybe someone from KNIME could weight in.

The flows are all scheduled by the same user - as we all use the same user to do this. So it shouldn’t be a problem to see the flows (technically). I can connect to it and I don’t get an error code from JSON like 401 or access denied etc.
And I use the User with which we schedule the flows to login.

I sometimes also had a null result but I cannot tell you exactly what I changed and I am not at the machine at the moment. Is your Kerberos ticket up to date - if you use it?

I have no clue what a Kerberos Ticket is :smiley:
I tried so far to run it locally, on the server and via WebPortal - hopefully some of the KNIME Teammembers has some input on this :slight_smile:
But thank you so far for your assistance, @mlauber71

1 Like

It is a way of authorising your access to certain resources and databases. But if you do not use it it will not be the problem.

1 Like

Hi @Chaosprinzip,

after providing the credentials and server connection in the first step and the execution of the workflow: if you have a look at the result of the GET request, is there only one empty dataset (fields are missing, symbolized with a red question mark) or is there a proper answer?

How are your mountpoints configured, also using REST? You can check this on the Analytics Platform by clicking on the document symbol in the upper right corner of the KNIME Explorer and choosing edit for the server connection. Please use the same Server address and port as configured there for the workflow settings (if “Use REST” is activated).

Did you already succeeded in using REST for server requests within workflows?



Hey @MichaelRespondek , thank you for your reply!
I could already successfully run the “Query jobs” flow which was posted earlier and got results from it.
When I run the “List scheduled jobs on KNIME Server” flow - I get an empty list with only questionmarks in one row.

And the flow has nearly no runtime so I start it and it immediately finishes.

The Mount Point has use REST ticked so this should be fine and I use the same address and port as in the mount for the flow.

Could it be an runtime error? Because we have a few thousand flows?

I just saw that when I run it it gives an error message in the Console:
Call #1 failed: java.util.concurrent.ExecutionException: javax.ws.rs.ProcessingException: java.io.IOException: IOException invoking https://xxx: HTTPS hostname wrong: should be xxx

(I x’ed the addresses)

Can you please post the settings of the GET Request node, with any confidential information blurred? This might be some certificate hiccup, so just for the sake of trying, can you please check the options “Ignore hostname mismatches” and “Trust all certificates”? (especially the first one)


Hey @RolandBurger thank you for your reply :slight_smile:
Here is the Request node :

After ticking Ignore hostname mismatches and trust all certificates I get status 200 but with this body:

Based on the URL, you’re actually querying the logs, rather than the scheduled jobs. Can you confirm if you overwrite that setting via flow variable? The endpoint should be /knime/rest/v4/scheduled-jobs.

That being said, your response looks a bit weird - if this was the actual log files, you should get a binary blob rather than html.

After changing to scheduled jobs I get this error in the console:

Call #1 failed: java.util.concurrent.ExecutionException: javax.ws.rs.ProcessingException: java.lang.IllegalArgumentException: protocol = https host = null

Can you please confirm whether you just used the workflow as it is provided in the examples without changing anything?

If yes, the GET Request should get its target URL from the “Enter KNIME Server Credentials” component. Can you please post the output of that component’s flow variable connection? If there is too much to blur out, you can also send it to me via private message.


I managed to get it working now, it seems that due to me using an older version one variable was not set correctly which resulted in the failing of the execution, but it worked now :slight_smile:
Thank you for your help Roland!

Awesome, glad I could help! :slight_smile:

1 Like