Palladian - HashCalculator - Hashcode column name

I’ve experienced a strange behaviour of Palladian’s HashCalculator node. I’ve already accepted the fact the node appends new column which name consists of the name of the column the hash is computed for and algorithm name, so that the new column’s name may look like “mycolumn (SHA1)”. It’s easy to rename the column subsequently in such a case. The magic starts after I collapse my nodes (usually Column Combiner to get a source for hash, HashCalculator itself, Column Rename and Column Filter) into Meta Node. Once executed, I can see the name of the new column the HashCalculator generated isn’t named after the name of the column the hash is computed for anymore but rather that after another, I’d say randomly chosen, column.
I’d consider it a bug and I’d like to know whether anybody already experienced this behaviour and how they dealt with it.

Update: Not only is the column name wrong, the HashCalculator ignores which column to generate the hash.
I’ve elaborated the behaviour a bit more and figured out when HashCalculator appears in Meta Node it ignores its setting and compute hash from the the first column of String type in the table. So the name of the new column is OK but its value is based on different column than it is configured for.

Well, meanwhile, is there a more reliable way of computing hashes based on string columns in KNIME workflow?

I cannot reproduce this. Can you please post a minimal example workflow including a step-by-step description which demonstrates the issue?

– Philipp