Parameter Optimization Running Time is Too Long


So I have around 60.000 rows and 900 columns of historical data for training and with parameter optimization, the running time for the process is too long.

I was wondering whether there are any thing I can do fastened the process?


make sure that you do not use “brute force” and check each variable. Also the question do you really need 899 features?

1 Like

Currently I am running with “backward feature elimination” and these 900 columns contain all binary values for my inputs such as product ID, holiday, and others. But, for feature selection I only select around 40 columns for the features.


So you run your optimization on 40 not 900 columns ?
And this still takes too much time? Maybe you could try different optimization techniques provided in the node

I think I know why it runs so slow, it is mainly because I wanted to use multi algorithm and next determine the best model. It is because I run all algorithm at the same time that caused to run time so slow.

Maybe you know any other idea if I want to use this kind of approach and utilize the parameter optimization node?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.