PCA Apply node, replace original data columns

I have been using the PCA apply node (Knime 2.10.0) and am getting inconsistent behavior with the "Replace original data columns"  setting.  The first time I ran the workflow I got the number of dimensions I had set in the "Dimensions to reduce to" field.  However if I run the workflow again, I now get all of the original data columns in addition to the requested dimensions.  I tried to delete the node and place and configure a new node into the workflow, but I get the same resulst. 


Hi Doug, 

That is quite weird, it seems to work as expected for me, even with variable column inputs. Do you have any more details or an example workflow demonstrating the problem?

Best regards,



I have a similar problem with knime 3.2. When I try to use the node PCA Compute -> PCA Apply on a dataset with 1002 columns the feature "Replace original data columns" does not work (as a result i have the original column + the principal components) and the column considered by the node are only 15!!!


If I use the "PCA" node I get this message: "using as default all possible columns (15) for PCA".

But if I replace the node with a new one I get this message: using as default all possible columns (1002) for PCA

Is it a bug?