PKIX Error On Excel Reader

Hey all, I am in the processing of conducting user acceptance testing of KNIME 4.2 for my organization. The Microsoft Authentication and SharePoint Online Connector work fine and the Excel Reader node allows me to navigate through files stored in SharePoint. The issue is that when I try to load the file into the node I receive an error that says

could not load file PKIX path building failed....unable to find valid certification path to requested target

What do I need to tell IT in order to overcome this issue? I really appreciate any insight or assistance you can offer!


did you add the .... or is that the full output, if not it would be good to know what’s written there.

1 Like


The node lets me navigate through my SharePoint site and when I select the file to load it gives the below error:

1 Like

Hi @TardisPilot,
This error message usually means that you are missing a certificate for the SSL connection to the server, i.e. your client cannot determine if the server is really who it says it is. To fix that, you need to import the server’s certificate into KNIME’s certificate store. How this is done is described here.
Kind regards


Hi @AlexanderFillbrunn,

Thank you for the reply. I will look into it!

So I have been looking into it and for testing I decided to try this on my local machine (rather than the Remote Desktop I’m required to test through).

On my local machine, I changed the Network Connection settings to Manual and added * and the defaults for Proxy Bypass. Once that change was made, everything worked great, it connected to SharePoint and pulled in a file no issues. I didn’t need update any certificates or anything.

Back on the Remote Desktop I tried the same thing and I even added * to Proxy Bypass but I still get the PKIX error. As far as I can tell the certs are fine. I’m starting to think it’s a connection/Proxy Bypass issue.

Is there any documentation about what should be added to the Proxy Bypass settings? Or has anyone had experience dealing with this issue specifically? There are quite a few threads on here about the PKIX issues that can crop up.

(As a note, I’m connecting to Remote Desktop via a VPN connection to the internal network)

I really appreciate it!

Hi @TardisPilot,
When you use the remote desktop to work on another machine, the network traffic from that machine might be routed through a proxy physically, so that the software bypass settings won’t help you. I think you need to find out what network restrictions there are in place from the remote machine’s point of view. Kind regards,


Hi @AlexanderFillbrunn,

Agreed. I will see if I can track something down. Thank you for all the help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.