POST Request Node - Read timed out errors

I’m using POST Request node for repeated API calls. Some of them come back with Status=“?” and Error Cause = “Read timed out”.

Is there a way to increase time for POST request read timeout in KNIME?

I tried setting “Timeout(s)” option (in Connection Settings for POST request node) to a large number, but it didn’t resolve the “Read timed out” messages.

Hi @svetlana_r and welcome to the forum.

Is it the same POST requests that fail each time, or is it seemingly random? If the latter, you might check out the Try/Catch construct in KNIME to collect the requests that didn’t go through, and try them again a second time. Here’s an example WF:

1 Like

Hi @svetlana_r and welcome to the Knime Community.

On top of what @ScottF is asking, can you give more details about what you mean by “repeated API calls”? How many calls are you talking about? And are you waiting between each call?

By default, the POST Request node sends all the requests simultaneously (concurrently), that is if you are reading off a table, with no wait in between - both of these settings are configurable in the POST Request node itself.

If you are sending a lot of concurrent POST requests, chances are the server is not able to handle all these requests at once - and you might risk getting banned too, because in this case, you’d be abusing the server.

Can you show us what you are doing?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.