[Problem] Undefined column type. How to change the column type to String?

I was about to export all my analysis to CSV Writer, until I got a message, “Input table must only contain String, Int, or Doubles”. I checked my previous node and found out that Rule Engine Node does not define my column type. Instead, it shows “?”.

On the Rule Engine Node, I was trying to append to a new column and name it as “IATA (2)”.


Anyone know how to change the column type to String?

Hi @HeroVax , There are a few ways to do this. Any node that generates data, you can overwrite the column and specify the type.

The easiest way is probably doing a Column Rename, where you rename it to the same name, but you can change the type to String:




Hello @bruno29a
That’s what I’m talking about man! Thanks again! :clap:

@bruno29a / @HeroVax using the rename node to change column types might result in unwanted effects. So it might not be the best option. Maybe using a String manipulation might be better?

@HeroVax could you provide an example?

Hi @mlauber71 , yes, for some content, it might be a problem. If they’re all strings, it should be no problem.

The Column Rename would be the fastest and easiest one, if @HeroVax 's content allows it.

Otherwise, yes, converting to String using the string() function via String Manipulation would be safer.

1 Like

Hello @mlauber71
I believe the issue starts in one of my statements in Rule Engine Node. I specify my statement to find this regular expression and set it to FALSE. I didn’t know it will change to boolean afterwards. That’s why it changes to undefined column type.

The reason why I wanted to do this way because, in the next Node (Row Filter) , I will search the word “false” and remove them from my field.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.