Problem uploading component from Knime Analytics Platform to KNIME Hub

Recently I encountered an issue while uploading a component I created to KNIME hub. The upload failed and the error message read:

An internal error occurred during: “Upload of Plate well expansion (Component - config) to My-KNIME-Hub:/Users/xxxxxxx/High-Throughput Screening Tools/Plate well expansion (Component - config)”.
java.io.IOException: Server returned HTTP response code: 500 for URL: https://api.hub.knime.com/knime/rest/v4/repository/Users/xxxxxxx/High-Throughput%20Screening%20Tools/Plate%20well%20expansion%20(Component%20-%20config):data

May I know what it means? I have no problem uploading (or rather transferring) the same component into another local folder in my KNIME explorer. I would right-click the component → Component → Share to upload it to KNIME hub (in the KNIME explorer), and I could do this for all other components except this particular one. Is there something in my component that is preventing its upload to KNIME hub?

Your feedback would be much appreciated.

Thanks,

Hi @ndwulst

Can we know which version of KNIME AP are we using? Also did we try to disconnect the HUB and connect back again with user details. Post which can we try once again to upload the component to KNIME HUB?

Also can we know if there are any external nodes used inside the component?

Regards,
Nagarjun S

Hi @nagarjun36

Thanks for getting back to me. I am currently using KNIME AP 4.6.1. I have disconnected the HUB and connected back again, but still encounter the same issue. I have attached the workflow with the component that I wanted to upload to the hub - the component is located at the top left corner. If I am not mistaken I don’t think I have any external nodes inside the component. Meanwhile, since I last posted the previous message, I was able to upload another component into the hub without much problem.

Regards,

Hi @nagarjun36,

I too hit what appears to be a similar issue to @ndwulst this evening.

Attempting to share a specific component on the hub repeatedly resulted in the error pasted below. I tried creating another component (basically turned a single table creator into a component) and attempted to upload that and it worked without issue. I also tried logging out of the

The component in question contained only standard KNIME nodes, and the only thing I can think of, of note, was that the java snippet node has this “Additional Bundle” specified.

I’m on KNIME AP 4.6.2 [Edit - and I’ve just updated to 4.6.3, but same problem occurs]

The workflow containing the component is here:
Test ip address in subnet.knwf (3.4 MB)

– details of error –

java.lang.RuntimeException: java.io.IOException: Server returned HTTP response code: 500 for URL: https://api.hub.knime.com/knime/rest/v4/repository/Users/takbb/Public/Components/IP%20Subnet%20Address%20Comparison:data
	at com.knime.explorer.server.internal.view.actions.WorkflowUpload.runSync(WorkflowUpload.java:157)
	at com.knime.explorer.server.internal.view.actions.WorkflowUpload$2.run(WorkflowUpload.java:331)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
Caused by: java.io.IOException: Server returned HTTP response code: 500 for URL: https://api.hub.knime.com/knime/rest/v4/repository/Users/takbb/Public/Components/IP%20Subnet%20Address%20Comparison:data
	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
	at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
	at java.base/java.lang.reflect.Constructor.newInstanceWithCaller(Unknown Source)
	at java.base/java.lang.reflect.Constructor.newInstance(Unknown Source)
	at java.base/sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
	at java.base/sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.base/sun.net.www.protocol.http.HttpURLConnection.getChainedException(Unknown Source)
	at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
	at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
	at java.base/sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
	at com.knime.enterprise.client.rest.RestUploadStream.close(RestUploadStream.java:268)
	at com.knime.explorer.server.rest.RestRemoteUploadStream.close(RestRemoteUploadStream.java:83)
	at com.knime.explorer.server.internal.view.actions.WorkflowUpload.uploadWorkflow(WorkflowUpload.java:316)
	at com.knime.explorer.server.internal.view.actions.WorkflowUpload.runSyncInternal(WorkflowUpload.java:241)
	at com.knime.explorer.server.internal.view.actions.WorkflowUpload.runSync(WorkflowUpload.java:148)
	... 2 more