Problem with installation

After installing the Palladian extension, I encountered the following messages in my console log. Any advice? TIA!

WARN DBTypeRegistry Uninstantiable default attribute definition supplier for the database type of ID databricks in extension:org.knime.bigdata.databricks
ERROR SparkProviderRegistry Problems during initialization of Spark provider with id ‘org.knime.bigdata.spark.core.databricks.DatabricksNodeFactoryProvider’. Exception: Plug-in org.knime.bigdata.databricks was unable to load class org.knime.bigdata.spark.core.databricks.DatabricksNodeFactoryProvider.
ERROR SparkProviderRegistry Extension org.knime.bigdata.databricks ignored.
ERROR RepositoryManager Node ‘org.knime.bigdata.dbfs.node.connector.DBFSConnectionInformationNodeFactory’ from plugin ‘org.knime.bigdata.databricks’ could not be created. The corresponding plugin bundle could not be activated!

Palladian does definitely not interact nor interfere with the mentioned plugins.

Are you, beside the warning messages, experiencing any troubles? If not, I’d suggest to simply sit back and relax :slight_smile:

If you experience strange behavior (e.g. other plugins or node not showing up or causeing issues): There seem to be issues with the way KNIME (or Eclipse, OSGi, P2, … the underlying technologies) handles modules/extensions recently (no matter if it’s KNIME-native or third-party). If you read a bit through the forum (search e.g. for “node disappeared”) you will find some posts about these troubles and also some suggestions how to potentially solve them – afair there seems to be a ominous “clean” parameter with which KNIME has be started and which seems to help in some cases.

–Philipp

1 Like

Hi Philipp,

You’re right, besides the warning messages, there doesn’t seem to be any issues when running the nodes. Read in another thread which recommended reinstalling some of the Big Data extensions - I tried that (reinstalled all my Big Data extensions) and it worked! Thanks!

1 Like

Hi alishakun,

great to hear, thanks for letting me know!

–Philipp