Problem with installing text processing extension

Hi,

I got a problem with installing the text processing extension (3.7.1.). Installing other extensions worked totally fine, but here I get this error:

An error occurred while collecting items to be installed

session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

Unable to read repository at http://update.knime.com/analytics-platform/3.7/knid=01-804315de98555fb0/org/3.7/3.7.1/plugins/org.apache.tika.app_1.18.0.jar.

Read timed out

I tried it with two different Windows machines and changed the default for the timeout in knime.ini, still a time out. The progress always seems to stop at 49% of the 66MB .jar file.

Any other ideas how I could solve this?

Thank you!

Do you have a virus scanner that scans all internet traffic? Then it could cause the timeout because that particular file is rather large.

1 Like

Hello @thor,

yes, I have a virus scanner and changed the settings in knime.ini like this (which i googled):
-Dorg.eclipse.ecf.provider.filetransfer.retrieve.readTimeout=10000
-Dorg.eclipse.ecf.provider.filetransfer.retrieve.retryAttempts=100
-Dorg.eclipse.ecf.provider.filetransfer.retrieve.closeTimeout=3000
-Dorg.eclipse.equinox.p2.transport.ecf.retry=15
-Dsun.net.client.defaultReadTimeout=30000

Still not working unfortunately. Other extensions (e.g. Source for Text Processing, Python Integration) worked totally fine, but I got the same problem with Text Processing - Deeplearning4J Integration.

Then you probably need to increase the timeouts even further. Or tell your virus scanner to not inspect data from our update sites any more.

Used another network, worked with that. Thank you!

1 Like