Problem with Model Reader after last update


I have a problem with the new model reader node after the update. What I want to achieve is that a user can select a model via the “File Chooser Widget”. Then after that, this model is given via a flow variable to a model reader node. This worked fine before the new Knime update, but now we are running into errors.

knime_forum_reader.knwf (15.6 KB)

Question: Why isn’t it possible to give the model location via a flow variable to the new model reader node? Take a look in my workflow. It isn’t possible anymore to select via variable. How can I solve this problem? I urgently need this.

Best regards,

Hello @ArminFan,

new Model Reader is based on new file handling framework (more about it you can find here) and requires flow variable type path while File Chooser Widget node produces flow variable type string. One way to deal with it is to use String to Path (Variable) node after Table Row to Variable node.



Hello @ipazin ,

thanks this works, if the user selects a file. But what if the workflow is executed with the default file selection:

This works on my local machine, but on the server directly I get the error:


What is the preferred way here?


Hi @ArminFan,

The Default File configuration contains the knime://knime-server2 mountpoint which is unknown for the KNIME Server’s executor. You could ask your KNIME Server Administrator to add a mountpoint named knime-server2 in the executors client-profile configuration.

As the mountpoint/mount-id could be configured differently on your colleague’s KNIME Analytics Platform (KAP) all the different named mountpoints would be needed to be added to the executor’s configuration to enable the usage of these mountpoints for all colleagues.

Easier would be to change the knime protocoll address in the Default File starting with:
This will use the current mountpoint, so it will use local when executed on the KAP and the KNIME Server’s repository if executed there.



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.