Problem with Python Script

I’m trying to use workflows from the Hub Python Script Space. For example:

If I use the Columnar Backend I get the following error:
ERROR CSV Reader 3:1 Execute failed: Unable to create DataContainerDelegate for ColumnarTableBackend.

CSV Error

If I use the default backend, the CSV Reader works, but the Python Script node doesn’t start Python. I’m using the Bundled “environment.”

Can some one please help?

@rfeigel it might be you have to re-install the Columnar Backend extension and also the Conda extension. Maybe best to do a complete re-installation of KNIME.

If you still experience problems you might want to send us a DEBUG Logfile and more details about your system.

Did a complete reinstall and get this error:

ERROR Python Script 3:2 Failed to initialize LZ4 libraries. The Columnar Table Backend won’t work properly.
ERROR Python Script 3:2 Execute failed: C:\Users\genef.javacpp\cache.lock (Access is denied)
ERROR Python Script 3:2 Error loading model settings
ERROR Python Script 3:2 Execute failed: Could not initialize class org.knime.python3.scripting.Python3KernelBackend

I tried and it worked properly. Maybe you can try different python scripts to see whether the issue is universal for you.

I tried this workflow:

Used Bundled environment and columnar backend. Same problem as earlier. The script starts to run but doesn’t seem to load Python. Is there some trick to using “Bundled”?

This path looks very strange. Is this indeed where you have installed something?

You might want provide us with a debug log file:

Then I have collected these hints. You might want to check if they give you an additional idea:

1 Like

@mlauber71 Thanks for your interest and time. I manually created the “Bundled” environment and it works. I’m puzzled why the Bundled environment doesn’t work as downloaded.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.