Problem with server profiles after updating my KAP to 4.4.2


After updating my KAP to 4.4.2 our corporative profile synced with KNIME Server doesn’t work properly on my KAP. I have lost the database drivers config (oracle, Impala…) and our update zips (in network folder).

Previously the automatically created local path for this profile was:

Now it has changed to:

Users still using KAP 4.4.1 don’t have any problem with this profile, and they have the epf file and other configuration files in a path org.knime.product\profiles<profile_name>.

I tried to disable/enable the profile without success.

Any idea?

Hello @jricgar,

Do I understand it right, that you are using the Customization Profile feature of the KNIME Server to provide the profile epf files to your executor as well as the KNIME Analytics Platforms? Do you ship the jdbc db drivers together with the profile?

The configuration of the executors configuration profiles was formerly done within the knime.ini, now it should be part of the service you set up for the executor.

Could you please elaborate?
On which OS is the executor running and do you use a service to maintain the starting and stopping of the executor instance?


We are just using the corporative profile for all the KAP clients, not for the Server Executor. We “ship” the JDBC drivers and update zips with the profile.

I think this isn’t related to the executor anyway. Our KNIME Server running over Linux, and we have a service for starting and stopping the executor.


Thanks for the clarification. In general there were no changes in the path which is used to store the downloaded profiles in your knime workspace. It should still be


So I assume that there went something wrong during the update. Could you try to stop the KNIME Analytics Platform, delete the profile-download12298932109690921560 as well as the profile folder and start again? The right folder should be created on the next startup automatically.


Hello Michael,

I did it several times, without success, before writing here in the forum. Each time I restarted my KAP, the previous profile-downloadXXXX folder was deleted, and a new one was created.

Finally, I opted to add the needed drivers by hand, pointing to the last profile files download folder (profile-download12298932109690921560), while keeping the profile selected, although it didnt add any driver or resource to my configuration.

Today, after your suggestion, I checked my KAP again just to discover the configuration profile seemed to be working properly then, and this is what I had as database config:

The highlighted options were the two drivers (Impala and Oracle) I added manually. Just for Impala, I used the same driver name (impala_conector) that is configured by the profile, so I suppose that is the reason it wasn’t added again.

The two drivers added manually some days before:

And one of the profile configurations:

This is now my org.knime.product folder:


I deleted the drivers added manually (impala_conector and oracle_dirver), and immediately the impala_connector was added again as part of the profile configuration:

Then I restarted my KAP, but profile-download12298932109690921560 wasn’t deleted automatically, so I deleted it manually.

Just for your knowledge.

Thanks for your help.

1 Like

Thank you for your feedback. Good to hear that it works now again.