Problem with Topic Extractor(parallel LDA) - Advice?

Hello, I experience some issues with the use of the Topic Extractor Node. Even though I do everything correctly, the third output(iteration) becomes empty (rows are equal to zero). The other two outputs (Document table with topics and topic terms) is just fine, it is only the third output (iteration statistics) that gets empty. Have tried in different workflows, checked the numbers (use of , and .), tried different number of threds and I have also gotten an executed workflow from another person where I could see the iteration output - but when I executed on my PC the same workflow it became zero again…
Workflow is attached. Any advice?

Topic Extractor Problem.knwf (2.9 MB)

Hi @Nadine_H and welcome to the forum.

Sorry for the trouble! This definitely looks like a bug, and one of our data scientists filed a ticket for it last week (AP-17814). This issue has come up in the past and was a bit hard to reproduce, so thank you for providing a workflow that clearly demonstrates the problem. Once there is news to report, someone will update this topic in the future.

Cheers!

3 Likes

Dear @Nadine_H :

thanks for the information. To narrow it further down, could you (or anybody else who experiences the same issue and reads this thread) please help me with the following questions?

  1. Does this issue occur in Knime AP 4.4.2? Or somewhere else as well?
  2. Do you use Windows/Mac/Unix? Also, which version?
  3. Maybe the most interesting; you mentioned working workflows from other persons, could you tell differences between your computer and theirs?

I apologize, so far this is a bit tricky as I and my team-mates cannot reproduce it yet.

Thanks
Steffen

3 Likes
  1. Please append the Log file. For this, go to PreferencesKNIME and choose for Log File Log Level the option DEBUG. Then execute the workflow with the issue. Finally, go to workspace /.metadata/knime/knime.log and copy that knime.log here into the Forum.

Thanks!

1 Like

Hi all. For the workflow provided here, I could not reproduce the issue after resetting all nodes (except for the Excel Reader) followed by re-execution of everything (with configurations intact). Here’s my iteration output:

1 Like

Hello :slight_smile:

  1. Yes, I have also tried to update and then try again, still same problem.
  2. Windows 11. I have an Acer computer.
  3. I could not tell a difference between me and theirs, that’s what made it so confusing.
  4. I tried to do this, and the knime.log is attached as a text file.
    knime.log 05.03.22.txt (142.2 KB)

Hello Steffen. Thanks for your help on this. Please let us know if you need more examples.