Problems implementing R in Knime

Hi everyone,
I have a problem with the implementation of R in Knime. I downloaded the version 3.6.1 of R and I did all the procedures for implementing the software in Knime, but every time I use the R nodes in Knime they give me this two errors:
-ERROR R Source (Table) 3:300 Execute failed: R evaluation failed.: “knime.out[1:150,5]” (outside the node)
-ERROR: Could not execute internal command.ERROR: R evaluation failed.: "sapply(ls(),function(a)class(get(a,envir=globalenv()))[1])"ERROR: R evaluation failed.: "sapply(ls(),function(a)class(get(a,envir=globalenv()))[1])"ERROR: eval failed (inside the node).

Could you help me?
Thank you,

Dear Camilla

Not sure if this helps, but I remember getting similar errors when I was trying to use an account-specific installation of R instead of the systemwide R on my Linux system. I could not figure out how to fix the problem, so I went back to the system R, and then it worked again. So, if you are working under Windows, installing R as admin may perhaps solve the problem :grimacing:

Or you could wait for advice from more knowledgeable people…

Good luck


You could read this entry and see if it can help you with KNIME and R:

Or maybe you could provide us with more information about your environment. You might use this workflow to get insights:


Thank for your answer!
I solved the problem thanks to your help! I was missing some packages to install and now I managed to connect R a Knime.
:slight_smile: Camilla


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.