Problems trying to restart kime executor

Hi im trying to restart knime executor using knimeexecutor.service but service it is not restarting.

following error appears:

!MESSAGE Problems occurred when invoking code from plug-in: “org.eclipse.equinox.preferences”.
!STACK 0
java.lang.IllegalStateException: The platform metadata area could not be written: /opt/knime/knime-4.4.1/workspace/.metadata. By default the platform writes its content
under the current working directory when the platform is launched. Use the -data parameter to
specify a different content area for the platform.

i tried restart using other user different to knime and it works fine the executor restart, buy no status appears on web portal for executor.

Can anyone help me with this issue?

Best

Did you install the KNIME Server and Executor on your own, or are you using a pre-built image from AWS or Azure?

The error lead me to believe it’s trying to start the GUI, or maybe the executor (server adapter) is not installed.

Also, can you confirm the user listed in the knime-executor.service matches the user that either owns the knime install folder, or has full access to those folders.

-Jeff

Hi,

yes the installation was a prebuilt image. i wanted to upgrade executor but didn’t work so i reverse the operation. is there a way to check if the installation is rigth? I did use the installation user (knime ) but
executor didn´t start keeps inactive. once i changed to admin user start running but i can´t visualize the executor in the web portal

When you say upgrade the executor, can you expand on that? From which version to which version?

Some executor upgrades require replacing the executor, as with certain changes the executor cannot be upgraded in place. Also, did you upgrade the webportal at the same time? They should be kept in sync, plus there were some changes to how queues are created that could also be an issue if the versions are not in sync.

It highly discouraged to run any knime server as an elevated user. This would give the executor elevated privileges, and could be a security risk.

You can look for the executor workspace, and pull the logs from that directory. It should have messages on why the executor isn’t connecting.

On the linux machine
sudo systemctl edit knime-executor.service

Then find where the executor workspace is pointing to.

Then within that directory there should be at least a knime.log file, possibly a .log file (hidden by linux). If you can provide those logs, or post the contents (if nothing sensitive) that may help figure out the issue.

Hi,

Sorry for the delay. I found the log and tried to start using

start-executor.sh

this is the result of the log

As you can see it looks like to call rabbit mq but no rabbit MQ is installed, ti guess it si a asetting but i didn’t found a wrong confing in executor knime.ini

below the knime.ini for executor

Using the start-executor.sh file is for testing, and by default does not set a lot of parameters like your picture shows.

You could set those via bash in your shell, but ideally it would be best to understand and figure out why the service scripts are not launching the executor properly.

This may be easier to work on during a call. If you send your request to support@knime.com we can create a a ticket and work through this issue.