Problems with setting up Python in KNIME

Hi everyone,

I ran into some troubles trying to run the python source node. “Could not start Python. There are problems with your Python environment:”

I tried going to preference to set my environment up. I put my correct directory to anaconda3 and also made sure anaconda is up and running on itself. However, I am stuck with this error message.

Does anyone know how to resolve this or what could be the cause?

Thank you!

@kathputu you will have to take a look at the Python 3 settings. Python 2 will in most cases not be used or necessary. So if you do not have a special need for Python 2 you can ignore the warnings.

Thank you for the reply!

I am wondering what do you mean by checking the python3 settings? Do you mean from anaconda or in KNIME. In addition, ff I ignore and just hit apply, I get the same error message when I try running the python source code.

@kathputu if you choose the bundled settings you can just set that up in the settings, maybe following the official guide:

You have two settings:

  1. where is conda

  1. which environment to use (bundled or your own one)

I have a longer article about KNIME and Python you might be interested in:


Ok, I will take a look into the article. Thank you very much!

1 Like


I have a follow up question - I wasn’t able to find a Conda tab under the KNIME tab in my preference. And my Python tab only has the Conda and Manual tab. I am wondering if you know why?

@kathputu I think the separate conda tab should be there since KNIME version 4.6. But the path itself should also work in earlier versions of KNIME. Which version are you using?

Oh I’m using the KNIME 4.5.1. I will update my KNIME and hopefully this will be solved!

Many thanks!!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.