Python Integration Anaconda Python 3.7 Windows 32-Bit

Hi All,
I tried to install the obove Integration but without success. Unfortunately there is only a descripton for Python 3.6.
I tried to install the needed packages manually but failed with pyarrow.
Can someone help?

Thanks,
Thomas

Hi @Tobl,

you don’t have to install pyarrow. I think it’s not available for 32bit. You can use the default flatbuffer implementations (no action required).

Did you check https://docs.knime.com/2018-12/python_installation_guide/index.html?

Cheers,

Christian

Hi @christian.dietz,

thanks for your reply.
I am trying to test my python Installation (without pyarrow by selecting Flatbuffers Column Serialization).
In my preferences - KNIME- Python Settings I see Python 3 Version: 3.7.3 - this is set as default. Python 2 is not installed so I get a red warning in this section.

In Python Scripting Settings I added the local path of python.exe.

To test the Integration i downloaded the Workspace “01_Python_Scripting” (Gaussian filter).

When I try to configure the node “Python Script (1=>1)” I get the error “Could not detect python Version”.

What could be wrong?

Best regards,
Thomas

Oh, many things could be wrong :slight_smile:

  1. The workflow “Python Scripting (Gaussian Filter)” is a test workflow for image analysis in Python. Is this what you want to test? If you want to simply test your Python setup, just use a standard Python (1=>1) node. This node will simply copy data (as an example). If this node successfully executes, your Python installation is just fine.

  2. Currently we only support Python 3.6.x (see Python installation guide ). Any chance you can use conda to setup Python? Please let us know if the guide is not clear or too complicated. We always want to improve the instructions!

We’ll make Python and KNIME work on your computer :slight_smile:

Best,

Christian

Side note: We know setting up Python is currently not super straightforward. However, with the new release (expected this summer), we made it much simpler to set everything up!

3 Likes

Oh, many things could be wrong :slight_smile:

-> seems so…

  1. I choose “Python Scripting” because it was the workflow I found - I will try to use Python (1=>1) node now. I will tell you the result.

  2. I used the Anaconda Distribution - the Version I found for Win 32 was 3.7.
    The guide is not too bad :slight_smile: - but for 3.6 :slight_smile:

Python is not the most important KNIME Topic for me - I just wanted to have all prepared.
Nice to hear that the Integration is getting improved.

BR,
Thomas

1 Like

Now I tried node Python Script (1=>1).
While configuring the node KNIME tries to start python - that fails with following error:

Could not start python kernel…

The console says:

ERROR PythonKernel ModuleNotFoundError: No module named ‘pandas.tslib’

Thomas

Hi @Tobl,

if you use a start script to activate the environment (as stated in the Python installation guide), Python 3.7 should just work fine.

If you go to the Python Preference page, are there any errors displayed for Python 3?

This problem results from a change in the pandas package from 0.23 to 0.24. I assume that you have 0.24 installed? If so, uninstalling and installing pandas 0.23 should fig the issue. To do so run the commands:

  1. activate your environment with activate <environment_name>
  2. conda uninstall pandas
  3. conda install pandas=0.23
1 Like

Hi DaveK,

Yes, I use a start script as described (adapted to 3.7).

No, I don’t have errors in the Preference page.

I downgraded Pandas via Anaconda Navigator which worked fine - and during the configuration of Python Script (1=>1) python started without an error!

Thanks a lot for your help Christian and Dave!

PS: I Extended my workspace according the Gaussian Filter example - it is also working now.

3 Likes

Hello, I am also encountering the issue of Python 3.7 (pandas) not being supported by the current version KNIME. Are you expecting the next KNIME version with Python 3.7 support to be released soon?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.