Python Learner stuck at loading

The python learner in Auto ARIMA Learner seems to have been stuck in loading and wont execute

Case_TimeSeries.knwf (2.0 MB)

Hi Adre,

I can’t reproduce your issue. Please provide information about which KNIME Analytics Platform version you used, which Operating System exactly, and the knime.log file for further investigation.

Additionally, when loading your workflow, I could update some components. Do you have your components up to date?

Best regards
Steffen

@Aldre you should make sure you have the bundled Python environment installed and configured.

The Auto ARIMA Learner – KNIME Hub will then just use the bundled vesrion:

Did you see major benefits with the bundled one? Great to have it but not being able to extend it seems a major drawback to me
br

@Daniel_Weikert if you are familiar with Python and environments and use YAML files and the Conda Environment Propagation you might not benefit that much from the bundled version. The main benefit is that a user would be able to use such Components (like the one mentioned) without having to go thru the installation process of Python. It makes these functions easier to use (this example only uses the bundled version: KNIME & Python Graphics - Boxenplot Plotting large distributions - using the bundled Python integration (KNIME 4.6+) – KNIME Hub).

And also KNIME is expanding the number of available packages:

3 Likes

Hi mlauber71,

thanks for the explanation; that is exaclty the use-case: letting people use the Python script node without the need to touch Python environments (or the Python Script preference page). For all more specific use-cases one has to create a customized Python environment either way. And yes, our selection of packages neither will nor can offer the whole world of available packages. Spoiler: but the chances are quite good that OpenPyxl will be part from 4.7.0 on :wink:

Best regards
Steffen

1 Like

@steffen_KNIME thank you for this spoiler. I understand that there will always be a balance between offering a broad variety of packages but also keep it stable, compatible and ‘clean’; because obviously stability is the main reason to have an integrated Python version in the first place. Anyone familiar with YAML and Conda can easily manage their own Python setup.

I use my curated Conda Environments called “Kaggle” for MacOS and Windows for KNIME but also for working with Jupyter notebooks. I am not yet sure if a one-environment-fits-all will be sustaiable for the future :slight_smile: - especially deep learning environments require special settings it seems (Train a simple Multilayer Perceptron using TensorFlow 2 – KNIME Hub). It might be an idea to provide a Python evnironment that is compatible with the Tensorflow and Keras integration from KNIME. There is support but for some people this still might be complicated and the guide is not always straightforward :slight_smile:

Yes, Tensorflow and Keras definitely deserve their own environments, but I cannot promise anything soon there. They also deserve some overhaul, e.g. guide-wise. But that is another topic. :slight_smile:

Since we are at it I wrote somthing down about deep learning environments. Also planning an article so that the informations are not always spread over several threads …

Thanks, let me know when you have the information bundled somewhere, that would help us!

1 Like

Best thing would be if the end user could extend it but that’s probably not doable.
Appreciate your great work @steffen_KNIME with anything python related (very interesting to me). Kudos to you and your fellow team members

@Daniel_Weikert I am not entirely sure, but that seems to be a use-case for the Conda Environment Propagation node; as that would allow cross-platform/cross-machine sharing of specific environments. So I would say that the functionality per se is given, but we could think about the convenience. Do you have thoughts on that?

That aside, we are very glad to hear that you appreciate it! It is always nice if some work is used by the community :slight_smile:

2 Likes

In certain company environments a user is not allowed to install python (that’s a shame!) so I am not sure whether it’s possible to provide it included in the KNIME zip version. But even if that is possible the user then would not be able to extend the libraries without using pip I guess.

I’m no expert in package management (yet), but yes, you would need some package manager to extend any environemnt, if it is not maintained by the Conda Propagation node. And if you have some package manager, you could also install Python.

So without a package manager, I don’t see how change environments.

1 Like