python script error..

Good Morning, good afternoon or good evening, depending on where you are right now :slight_smile:
i’m trying to play around with the “Decompose Signal” Component and everything seems to be running well until the python script ist being used. I read some topics here in the forum about the same error but wasn’t able to find the right solution since i think i did everything right with the conda and python integration. Have i overlooked something?

Did you install the statsmodels module in the py3_knime_dl environment?

no, i think not.
I really don’t know nothing about python either and i can’t find where to download/install modules in the chosen environment. Ist there a link or something where i can find instructions?
I also tried finding it out by myself in here but without luck.

If you don’t know anything about Python then it might be tricky.

One method is to use the Anaconda Navigator to install the package.

  1. Run Anaconda Navigator, click on Environments on the left, then select the KNIME environment (py3_knime_dl in your case) from the list.

  2. A list of installed packages will appear on the right. You can scroll through to see if statsmodels is installed. On my system, it’s already installed in the environment I use with KNIME:

  3. If statsmodels isn’t installed you can select “All” or “Not Installed” from the dropdown menu and search for statsmodels, select it, and click Apply.

The other method is to use the command prompt.

  1. Since you seem to be using a Mac, open the terminal and activate the KNIME environment with the command conda activate py3_knime_dl.

  2. You can check to see if the package is installed using the command conda list statsmodels. Again, in my KNIME environment it’s already installed and that command returns the name of the package, the version number and other information:

    This is what it looks like when I switch to a different environment where statsmodels is not installed:
    No results come up.

  3. If statsmodels not installed, then you can install it using the command conda install -c conda-forge statsmodels


Thanks a lot!! It worked!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.