Python Server Problem

Hi,

I want to run Python script on a remote server (on Ubuntu 14.04), so that I installed and started the Python server based on this instruction:

https://github.com/knime-mpicbg/knime-scripting/wiki/Python-server-for-knime

But on the client side (in KNIME on Windows), after setting the server ip and port, it cannot run. It yields the following error:

ERROR     Python Snippet                     Execute failed: java.lang.IllegalArgumentException: Connection refused to host: 127.0.1.1; nested exception is:
    java.net.ConnectException: Connection refused: connect

Did I miss something? Please help. Thank you!

-yingwei

Hi Yingwei

this sound like the server is not listening on the port. Did you check the iptables of the server?

The IP in the error message suggests, that you were trying to use the server on your local machine on which you also run the client. Do you need the server or is it enough to run the scripts on the same machine your working on? if the later is the case just tick the checkbox with the label "Run python scripts on local system (ignores host/port settings)" on the preference page (KNIME>Preferences, expand KNIME, click on "Python Scripting")

Felix

Hi Felix,

Thank you for your reply!

>> this sound like the server is not listening on the port. Did you check the iptables of the server?

On the remote machine, which has PyServer installed on Ubuntu 14, the iptables are empty. So there is no traffic blocked.

>> The IP in the error message suggests, that you were trying to use the server on your local machine on which you also run the client.

Interesting, actually I already set it to the remote server's ip address. But it complains a local ip address. I don't have pyserver running locally.

>> Do you need the server or is it enough to run the scripts on the same machine your working on?

I do need the server.

>> if the later is the case just tick the checkbox with the label "Run python scripts on local system (ignores host/port settings)" on the preference page (KNIME>Preferences, expand KNIME, click on "Python Scripting")

Yeah, it works on local machine. But I need to connect to the server.

Thanks,

yingwei