Python snippet cannot open-edit-create

Hello,

I have suddenly started seing the same error as dan_mason described in other post, that is, I cannot open/edit/create Python snippet nodes anymore. Scripts are working fine, it is just that nodes cannot be opened. I have quickly went after template links in Preferences->KNIME->Python scripting and by checking the default links found that server at idisk-srv1.mpi-cbg.de is down. I found the link below instead:

https://github.com/knime-mpicbg/scripting-templates/tree/master/knime-scripting-templates/Python/script-templates.txt

It should be pointing to the same file at github and thus I added it to the preferences. I have added the same github link to R-scripting preferences and still see the error when trying to work with Python snippet nodes:

Error while creating node dialog for 'Python Snippet': R-templates must start with a line with the scheme # name: blabla

Where do I go from he?

Thank you for any suggestions you might have.

The link is not correct. It should be

https://raw.githubusercontent.com/knime-mpicbg/scripting-templates/master/knime-scripting-templates/Python/script-templates.txt

The same applies to R template files (which are different from Python template files, you know that?) - it needs to point to the raw file at github.

The correct github links should be default for following releases.

 

Does it help?
 

The link looks weird, so once more:

https://raw.githubusercontent.com/knime-mpicbg/scripting-templates/master/knime-scripting-templates/Python/script-templates.txt

Adding and selecting the new link in Preferences ->-> Python scripting fixed the problem. Thank you.

To summarize, links to the latest Python and R templates should point to:

Python scripting:

https://raw.githubusercontent.com/knime-mpicbg/scripting-templates/master/knime-scripting-templates/Python/script-templates.txt

https://raw.githubusercontent.com/knime-mpicbg/scripting-templates/master/knime-scripting-templates/Python/figure-templates.txt

 

R-scripting:

https://raw.githubusercontent.com/knime-mpicbg/scripting-templates/master/knime-scripting-templates/R/openinr-templates.txt

https://raw.githubusercontent.com/knime-mpicbg/scripting-templates/master/knime-scripting-templates/R/snippet-templates.txt

https://raw.githubusercontent.com/knime-mpicbg/scripting-templates/master/knime-scripting-templates/R/figure-templates.txt

I had the same problem today, I did not notice this error in December but I cannot remind if I actually opened a Python Snipper dialog.

As I do not use the templates, I have just unchecked the current adress and the problem was solved.