"Python Source" node fails while executing task scheduled on KNIME Server.

I am facing this weird issue for last few days. I have a workflow in which i use Python Source node and it is working perfectly fine in my local environment. Then I upload the workflow to the KNIME server and then i can open the job again on the KNIME server and it executes fine again.

When i schedule the job it is throwing out an error that it is not able to find python executable at the given location. Attached is the screenshot below:

This error points out to the fact that the Python executable path is not set up the KNIME preferences. Is there any configuration file that needs to be manually updated. Any help is appreciated.

Hi there,
You’ll need to setup the server preferences to point to the Python installation on the KNIME Server. With recent server versions there is a file called /config/preferences.epf.template.

That contains the lines (paths are different):
The timeout is in seconds.

You can copy the preferences.epf.template file to preferences.epf and edit the preferences.epf file to set the preferences that you need (don’t remove the line file_export_version=3.0, or !/=).

Once you’ve made those changes restart the KNIME Server for the preferences to take effect.



Thanks @jonfuller