Question about Row filter node

Hello all, I’m learning KNIME to replace with Excel.

I tried to use ‘Row filter’ to exclude some rows, but I couldn’t exclude rows i wanted to delete.

I set ‘Exclude rows by attribute value’, I chose ‘Column to test’, and ‘use pattern matching’ then I entered keyword i wanted to exclude, checked ‘contains wild cards’.

However, when i see the filtered result i still found a rows i tried to exclude.

How can i fix this problem?

Hello @kimsd0826 and welcome to the KNIME Forum,

Could you please share with us your workflow? In case there is sensitive data, please delete it or change it to dummy data.

All the best,

Jose.

1 Like

Hello @kimsd0826 ,

Would you mind to share what the pattern you try to match? And the keyword you used to match the pattern?

Best Regards,
Jinwei

1 Like

Thanks for the reply

This is all data I can show you I’m sorry about that.

There are not so many work flows, I just have Excel reader, column filter(to exclude one column) and this row filter.

I want to exclude this rows start from ‘S~’ but I still can find those rows after excute in filtered data.

Thanks for the reply

This is all data I can show you I’m sorry about that.

There are not so many work flows, I just have Excel reader, column filter(to exclude one column) and this row filter.

I want to exclude this rows start from ‘S~’ but I still can find those rows after excute in filtered data.

hi @kimsd0826

Could you please reproduce with the same kind of pattern and data but without sensitive data and share with us the workflow with the Excel File and the Row Filter nodes?

All the best,

Jose.

Hi @kimsd0826

As you can see in the following image: with “S~*” pattern:

I am able to exclude rows starting from “S~”. You should check the “contains wild cards” option.

image

I hope this can solve your problem.

All the best,

Jose.

3 Likes