R "added library" error

So I'm trying to run a local R snippet using the dprep (data processing) package.  I'm been trying to run some of the discretization algorithms like chiMerge, but I'm getting the following error:

ERROR     R Snippet (Local)     Execute failed: Execution of R script failed: Calls: chiMerge -> table

I've tried outputting the data into a csv, loading it directly into R, and running the same command within R, and it works fine.  Here's the command:

a<-chiMerge(data1, 1:4, alpha=.05)

I don't understand why I'm getting the error.  It appears that "table" is actually another function within the dprep package.  Also of note, the dprep package is no longer maintained in CRAN, so that may have something to do with it.  I use other R snippets all the time without a hitch.  Anyone have any idea why I'm might be getting this error?  Or how I might get around it?

thanks in advance,

Casey

Just a thought - the R versions might differ. On a fresh install, KNIME uses its own R package, which may be either older or newer than the one you tried in manually. In order to make sure, check the "R executable" setting. You can set the R nodes to use your R installation by default in File / Preferences / KNIME / R.

HTH
E

Hi! A bit late for u, but I found a solution.

THe dprep package last built is 2.9, so it is not included anymore. You can start the R Gui (located in your Knime-Plugin Folder under ext.R.... and install dprep.

Here is a link where you can get it:

http://cran.r-project.org/    -> go to r binaries contrib->2.9 dprep

install it locally or remote (Muenchen Server)

if the error is still there, u need an older R-Installation. Therefor either install an older R-Inst in the same folder (rename the other one _Inst_backup) or you can install an older knime version (2.1), install the RPlugins and copy the R Installation to your new knime folder. Than install the dprep paket and it'll work.

If you didn't get the steps done contact me. I'll help u