R Error while updating Knime 4.5.1

Hi everyone thank you for your help, I downgraded the Knime version to the 4.5.0 and now is working

This is exact version


I did not touch the R versions o packages.

Thank you for your support

I guess that’s the second best outcome of that scenario, but I’m glad it’s working for you again.

1 Like

Hello everyone,

I have had exactly the same problem.

Upgraded to KNIME 4.5.1., and all R nodes upon execution gave the same error message @salazachou wrote.

Tried out installing a newer version of R, error remains.

Deinstalled KNIME installed 4.5.0. → Error is gone and I can work normally.

Cost us an hour of trial and error to get it fixed.
Maybe this is actually a bug in 4.5.1?

Best regards,

With a second case, chances of it being something else is close to 0 now. Let’s make sure this doesn’t get overlooked.

@Iris Can you notify one of your colleagues so they can look into it? I’m not sure who to summon. Thank you. :slight_smile:

1 Like

Hi @schuppius, did you had the same error message “Execute failed: ‘java.lang.String org.knime.ext.r.bin.preferences.DefaultRPreferenceProvider.findPathVariableName(java.util.Map)’” ?


1 Like

Thanks, but is weird since you already tried and worked.

I will try in my home computer, probably there is a restriction in my work computer


@Thyme from what I see there has been heavy editing in the specific parts of the R integration concerning the very path variables (to integrate the conda paths to an R installation) so I think it entirely possible that something went wrong under specific circumstances.

I was not immediately able to spot the problem. At a certain point the path gets replaced by something it should not … I see a removed blank and different PATH syntaxes …

Maybe @bwilhelm can weight in.


For what it’s worth. I’ve migrated to 4.5.1 too an my R-nodes still work as before. I’m using Windows10, own specified path to my directories containing R-3.6.3 (which is not a conda environment) and using RServe package 1.8-7.

1 Like

Yes, I did. Exactly the same.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hi everyone,
Sorry for joining the discussion so late. I am a bit puzzled how this issue only exists with 4.5.1 and not 4.5.0 because the commit in question was released with 4.5.0.

However, I would like to understand the problem to fix it. @salazachou, @schuppius, does one of you have a “stacktrace” of the error? You can find it in the KNIME log (View → Open KNIME log). I don’t see what could go wrong in this part of the code and a stacktrace would help me to locate the exact location.
Thank you!

1 Like

Hello @bwilhelm

since I have deinstalled the version that had the problem, I only have the error message “left”, and that is exactly as written by @salazachou above.

I don’t think IT will let me reinstall the newer version just for error tracing, sorry …

If there is anything apart from reinstalling that I can do, let me know!

Best regards,

Hi @bwilhelm I cannot replicate the error right now since I am at work, I will try to do it at home.

Probably the errors reported in the firsts messages can be useful by the moment


Hi there, I tried the R extensions at home with the 4.5.1 Knime version, but the software ran properly.

Sorry for not being able to replicate the error

@bwilhelm I think something is definitly off with the R KNIME integration since 4.5.1 - I had to move several integrations to the community edition in order for them to run:

does work (R community edition)

does not work (R KNIME integration)

See the Metanodes for H2O


@pio, Thank you for the log output! It helped me a lot. The MethodNotFoundError suggests that the plugin which contains the DefaultRPreferenceProvider has an incompatible version to the plugin which contains the RConnectionFactory. I will investigate how this can happen.


Hi @bwilhelm ,
I have updated my R to the latest version as well, but still the same problem. It doesn’t seem to initialise the R . I have also installed Rserve library and re initialised but no luck so far. At this point I am thinking of reverting back to an older version


Hi @pio,
The only workaround right now is to reinstall KNIME AP in version 4.5.1 (or 4.5.0 as others have stated).
We are working on a fix for the upcoming bugfix release (4.5.2) which should arrive very soon. If you wait for the bugfix release, you don’t have to reinstall KNIME AP but updating will work.

Update: KNIME AP 4.5.2 is released. Updating to 4.5.2 fixes the issue.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.